CVE-2022-24836

Inefficient Regular Expression Complexity in Nokogiri

HIGH
7.5
CVSS Score
Published: April 11, 2022 at 12:00 AM UTC
Updated: June 17, 2026 at 04:32 AM UTC
5 products affected across 5 vendorsmacOSDebian LinuxFedora

Using nokogiri by sparklemotion?

Get instant alerts when new vulnerabilities affect nokogiri - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
HIGH7.5
Exploit prediction
EPSS 4%

Description

Nokogiri is an open source XML and HTML library for Ruby. Nokogiri `< v1.13.4` contains an inefficient regular expression that is susceptible to excessive backtracking when attempting to detect encoding in HTML documents. Users are advised to upgrade to Nokogiri `>= 1.13.4`. There are no known workarounds for this issue.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

13.0 ≤ v < 13.1
Affected range stops below 13.1, so it looks safe — our inference, not a vendor statement
v < 1.13.4
Affected range stops below 1.13.4, so it looks safe — our inference, not a vendor statement
v < 1.13.4
Affected range stops below 1.13.4, so it looks safe — our inference, not a vendor statement

CVSS

7.5HIGHGitHub_M
Attack Vector
NETWORK
Complexity
LOW
Privileges
NONE
User Interaction
NONE
Scope
UNCHANGED
Confidentiality
NONE
Integrity
NONE
Availability
HIGH
Vector?

Quick Info

StatusMODIFIED
CWE
CWE-400CWE-1333

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card