CVE-2022-24822

Denial of Service in @podium/layout and @podium/proxy

HIGH
7.5
CVSS Score
Published: April 6, 2022 at 05:15 PM UTC
Updated: June 17, 2026 at 04:32 AM UTC
3 products affected across 2 vendorsPodium ProxyPodium LayoutPodium Proxy (@podium/proxy)

Using proxy by podium-lib?

Get instant alerts when new vulnerabilities affect proxy - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
HIGH7.5
Exploit prediction
EPSS 2%
SSVC
No known exploit

Description

Podium is a library for building micro frontends. @podium/layout is a module for building a Podium layout server, and @podium/proxy is a module for proxying HTTP requests from a layout server to a podlet server. In @podium/layout prior to version 4.6.110 and @podium/proxy prior to version 4.2.74, an attacker using the `Trailer` header as part of the request against proxy endpoints has the ability to take down the server. All Podium layouts that include podlets with proxy endpoints are affected. `@podium/layout`, which is the main way developers/users are vulnerable to this exploit, has been patched in version `4.6.110`. All earlier versions are vulnerable.`@podium/proxy`, which is the source of the vulnerability and is used by `@podium/layout` has been patched in version `4.2.74`. All earlier versions are vulnerable. It is not easily possible to work around this issue without upgrading.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

v < 4.6.110
Affected range stops below 4.6.110, so it looks safe — our inference, not a vendor statement
v < 4.2.74
Affected range stops below 4.2.74, so it looks safe — our inference, not a vendor statement
v < 4.2.74v < 4.6.110
Affected range stops below 4.2.74, so it looks safe — our inference, not a vendor statement
Affected range stops below 4.6.110, so it looks safe — our inference, not a vendor statement

Remediation

No guide yet

No remediation guidance has been written for this CVE yet. What the record does show:

SSVC — Action Prioritization

SSVCNo known exploitAutomatablePartial impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

7.5HIGHGitHub_M
Attack Vector
NETWORK
Complexity
LOW
Privileges
NONE
User Interaction
NONE
Scope
UNCHANGED
Confidentiality
NONE
Integrity
NONE
Availability
HIGH
Vector?

Quick Info

StatusMODIFIED
CWE
CWE-248NVD-CWE-noinfo

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card