CVE-2022-24749

Basic Cross-site Scripting and Unrestricted Upload of File with Dangerous Type in Sylius

MEDIUM
6.1
CVSS Score
Published: March 14, 2022 at 09:45 PM UTC
Updated: June 17, 2026 at 04:32 AM UTC
1 product affected across 1 vendorSylius

Using Sylius by Sylius?

Get instant alerts when new vulnerabilities affect Sylius - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
MEDIUM6.1
Exploit prediction
EPSS 1%
SSVC
PoC

Description

Sylius is an open source eCommerce platform. In versions prior to 1.9.10, 1.10.11, and 1.11.2, it is possible to upload an SVG file containing cross-site scripting (XSS) code in the admin panel. In order to perform a XSS attack, the file itself has to be open in a new card or loaded outside of the IMG tag. The problem applies both to the files opened on the admin panel and shop pages. The issue is fixed in versions 1.9.10, 1.10.11, and 1.11.2. As a workaround, require a library that adds on-upload file sanitization and overwrite the service before writing the file to the filesystem. The GitHub Security Advisory contains more specific information about the workaround.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

95%
v < 1.10.11v < 1.11.2v < 1.9.101.10.0 ≤ v < 1.10.111.11.0 ≤ v < 1.11.2
Affected range stops below 1.10.11, so it looks safe — our inference, not a vendor statement
Affected range stops below 1.11.2, so it looks safe — our inference, not a vendor statement
Affected range stops below 1.9.10, so it looks safe — our inference, not a vendor statement

Remediation

No guide yet

No remediation guidance has been written for this CVE yet, and no fixed version or vendor advisory is recorded against it.

SSVC — Action Prioritization

SSVCPoCNot automatablePartial impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

6.1MEDIUMGitHub_M
Attack Vector
NETWORK
Complexity
LOW
Privileges
NONE
User Interaction
REQUIRED
Scope
CHANGED
Confidentiality
LOW
Integrity
LOW
Availability
NONE
Vector?

Quick Info

StatusMODIFIED
CWE
CWE-80CWE-434CWE-79

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card