CVE-2022-24712

Cross-Site Request Forgery (CSRF) Protection Bypass Vulnerability in CodeIgniter4

HIGH
8.8
CVSS Score
Published: February 28, 2022 at 04:00 PM UTC
Updated: June 17, 2026 at 04:32 AM UTC
2 products affected across 2 vendorsCodeigniterCodeigniter

Using CodeIgniter4 by codeigniter4?

Get instant alerts when new vulnerabilities affect CodeIgniter4 - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
HIGH8.8
Exploit prediction
EPSS 0.6%
SSVC
No known exploit

Description

CodeIgniter4 is the 4.x branch of CodeIgniter, a PHP full-stack web framework. A vulnerability in versions prior to 4.1.9 might allow remote attackers to bypass the CodeIgniter4 Cross-Site Request Forgery (CSRF) protection mechanism. Users should upgrade to version 4.1.9. There are workarounds for this vulnerability, but users will still need to code as these after upgrading to v4.1.9. Otherwise, the CSRF protection may be bypassed. If auto-routing is enabled, check the request method in the controller method before processing. If auto-routing is disabled, either avoid using `$routes->add()` and instead use HTTP verbs in routes; or check the request method in the controller method before processing.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

4.0.0 ≤ v < 4.1.9
Affected range stops below 4.1.9, so it looks safe — our inference, not a vendor statement
v < 4.1.9
Affected range stops below 4.1.9, so it looks safe — our inference, not a vendor statement

Remediation

No guide yet

No remediation guidance has been written for this CVE yet. What the record does show:

SSVC — Action Prioritization

SSVCNo known exploitNot automatablePartial impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

Attack Vector
NETWORK
Complexity
LOW
Privileges
NONE
User Interaction
REQUIRED
Scope
UNCHANGED
Confidentiality
HIGH
Integrity
HIGH
Availability
HIGH
Vector?

Quick Info

StatusMODIFIED
CWE
CWE-352

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card