CVE-2022-23515

Improper neutralization of data URIs may allow XSS in Loofah

MEDIUM
6.1
CVSS Score
Published: December 14, 2022 at 01:23 PM UTC
Updated: June 17, 2026 at 04:30 AM UTC
3 products affected across 3 vendorsDebian LinuxLoofahLoofah

Using loofah by flavorjones?

Get instant alerts when new vulnerabilities affect loofah - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
MEDIUM6.1
Exploit prediction
EPSS 0.9%

Description

Loofah is a general library for manipulating and transforming HTML/XML documents and fragments, built on top of Nokogiri. Loofah >= 2.1.0, < 2.19.1 is vulnerable to cross-site scripting via the image/svg+xml media type in data URIs. This issue is patched in version 2.19.1.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

2.1.0 ≤ v < 2.19.1
Affected range stops below 2.19.1, so it looks safe — our inference, not a vendor statement
v < 2.19.1
Affected range stops below 2.19.1, so it looks safe — our inference, not a vendor statement

Remediation

No guide yet

No remediation guidance has been written for this CVE yet, and no fixed version or vendor advisory is recorded against it.

References (5)

x_refsource_MISCIssue TrackingThird Party Advisory
https://github.com/flavorjones/loofah/issues/101
x_refsource_MISCPermissions RequiredThird Party Advisory
https://hackerone.com/reports/1694173
Source: af854a3a-2127-422b-91ae-364da2661108
https://lists.debian.org/debian-lts-announce/2024/09/msg00044.html

CVSS

6.1MEDIUMGitHub_M
Attack Vector
NETWORK
Complexity
LOW
Privileges
NONE
User Interaction
REQUIRED
Scope
CHANGED
Confidentiality
LOW
Integrity
LOW
Availability
NONE
Vector?

Quick Info

StatusMODIFIED
CWE
CWE-79

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card