CVE-2022-23494

Cross-site scripting vulnerability in TinyMCE alerts

MEDIUM
6.1
CVSS Score
Published: December 8, 2022 at 09:29 PM UTC
Updated: June 17, 2026 at 04:30 AM UTC
2 products affected across 2 vendorsTinymceTinymce

Using tinymce by tinymce?

Get instant alerts when new vulnerabilities affect tinymce - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
MEDIUM6.1
Exploit prediction
EPSS 1%
SSVC
No known exploit

Description

tinymce is an open source rich text editor. A cross-site scripting (XSS) vulnerability was discovered in the alert and confirm dialogs when these dialogs were provided with malicious HTML content. This can occur in plugins that use the alert or confirm dialogs, such as in the `image` plugin, which presents these dialogs when certain errors occur. The vulnerability allowed arbitrary JavaScript execution when an alert presented in the TinyMCE UI for the current user. This vulnerability has been patched in TinyMCE 5.10.7 and TinyMCE 6.3.1 by ensuring HTML sanitization was still performed after unwrapping invalid elements. Users are advised to upgrade to either 5.10.7 or 6.3.1. Users unable to upgrade may ensure the the `images_upload_handler` returns a valid value as per the images_upload_handler documentation.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

v < 5.10.76.0.0 ≤ v < 6.3.1
Affected range stops below 5.10.7, so it looks safe — our inference, not a vendor statement
Affected range stops below 6.3.1, so it looks safe — our inference, not a vendor statement
v < 5.10.7v < 6.3.1
Affected range stops below 5.10.7, so it looks safe — our inference, not a vendor statement
Affected range stops below 6.3.1, so it looks safe — our inference, not a vendor statement

SSVC — Action Prioritization

SSVCNo known exploitNot automatablePartial impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

Attack Vector
NETWORK
Complexity
LOW
Privileges
NONE
User Interaction
REQUIRED
Scope
CHANGED
Confidentiality
LOW
Integrity
LOW
Availability
NONE
Vector?

Quick Info

StatusMODIFIED
CWE
CWE-79

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card