CVE-2022-22620

HIGH
8.8
CVSS Score
Published: March 18, 2022 at 05:59 PM UTC
Updated: June 17, 2026 at 04:28 AM UTC
4 products affected across 1 vendormacOSiPhone OSiPadOS

Using Safari (v and ) by Apple?

Get instant alerts when new vulnerabilities affect Safari (v and ) - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
HIGH8.8
Exploitation
CISA KEV
Exploit prediction
EPSS 16%
SSVC
Active

Actively Exploited

CISA Known Exploited Vulnerabilities (KEV) Catalog

EPSS Score16.3%

EPSS (Exploit Prediction Scoring System) estimates a 16.3% chance this CVE is exploited in the wild within the next 30 days — higher than 97% of all CVEs. It complements CVSS: a high EPSS on a mid-severity CVE can still be urgent.

Apple iOS, iPadOS, and macOS WebKit contain a use-after-free vulnerability that leads to code execution when processing maliciously crafted web content. This vulnerability could impact HTML parsers that use WebKit, including but not limited to Apple Safari and non-Apple products which rely on WebKit for HTML processing.

Required Action
Apply updates per vendor instructions.
Ransomware Use
Unknown
Added to KEV
Feb 11, 2022
Remediation Due
Feb 25, 2022
1708 days overdue

Description

A use after free issue was addressed with improved memory management. This issue is fixed in macOS Monterey 12.2.1, iOS 15.3.1 and iPadOS 15.3.1, Safari 15.3 (v. 16612.4.9.1.8 and 15612.4.9.1.8). Processing maliciously crafted web content may lead to arbitrary code execution. Apple is aware of a report that this issue may have been actively exploited..

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

v < 15.3.1
Affected range stops below 15.3.1, so it looks safe — our inference, not a vendor statement
v < 15.3.1
Affected range stops below 15.3.1, so it looks safe — our inference, not a vendor statement
v < 12.2v < 15.312.0.0 ≤ v < 12.2.1
Affected range stops below 12.2, so it looks safe — our inference, not a vendor statement
Affected range stops below 12.2.1, so it looks safe — our inference, not a vendor statement
Affected range stops below 15.3, so it looks safe — our inference, not a vendor statement
v < 15.3
Affected range stops below 15.3, so it looks safe — our inference, not a vendor statement

Remediation

No guide yet

No remediation guidance has been written for this CVE yet. What the record does show:

References (5)

Vendor Advisoryx_refsource_GENTOOThird Party Advisory
https://security.gentoo.org/glsa/202208-39
x_refsource_MISCRelease NotesVendor Advisory
https://support.apple.com/en-us/HT213091
x_refsource_MISCRelease NotesVendor Advisory
https://support.apple.com/en-us/HT213092
x_refsource_MISCRelease NotesVendor Advisory
https://support.apple.com/en-us/HT213093
Third Party AdvisoryUS Government Resource
Source: 134c704f-9b21-4f2e-91b3-4a467353bcc0
https://www.cisa.gov/known-exploited-vulnerabilities-catalog?field_cve=CVE-2022-22620

SSVC — Action Prioritization

SSVCActiveNot automatableTotal impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

8.8HIGHCISA-ADP
Attack Vector
NETWORK
Complexity
LOW
Privileges
NONE
User Interaction
REQUIRED
Scope
UNCHANGED
Confidentiality
HIGH
Integrity
HIGH
Availability
HIGH
Vector?

Quick Info

StatusANALYZED
CWE
CWE-416

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card