CVE-2022-22248

Junos OS Evolved: Incorrect file permissions can allow low-privileged user to cause another user to execute arbitrary commands

HIGH
7.3
CVSS Score
Published: October 18, 2022 at 02:46 AM UTC
Updated: June 17, 2026 at 04:28 AM UTC
2 products affected across 2 vendorsJunos OS EvolvedJunos OS Evolved

Using Junos OS Evolved by Juniper Networks?

Get instant alerts when new vulnerabilities affect Junos OS Evolved - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
HIGH7.3
Exploit prediction
EPSS 0.2%
SSVC
No known exploit

Description

An Incorrect Permission Assignment vulnerability in shell processing of Juniper Networks Junos OS Evolved allows a low-privileged local user to modify the contents of a configuration file which could cause another user to execute arbitrary commands within the context of the follow-on user's session. If the follow-on user is a high-privileged administrator, the attacker could leverage this vulnerability to take complete control of the target system. While this issue is triggered by a user, other than the attacker, accessing the Junos shell, an attacker simply requires Junos CLI access to exploit this vulnerability. This issue affects Juniper Networks Junos OS Evolved: 20.4-EVO versions prior to 20.4R3-S1-EVO; All versions of 21.1-EVO; 21.2-EVO versions prior to 21.2R3-EVO; 21.3-EVO versions prior to 21.3R2-EVO. This issue does not affect Juniper Networks Junos OS Evolved versions prior to 19.2R1-EVO.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

20.4-EVO ≤ v < 20.4R3-S1-EVO21.1R1-EVO ≤ v < 21.1-EVO*21.2-EVO ≤ v < 21.2R3-EVO21.3-EVO ≤ v < 21.3R2-EVO20.4-EVO21.1R1-EVO21.2-EVO21.3-EVO
Vendor states this is fixed in 19.2R1-EVO (unaffected)
Affected range stops below 20.4R3-S1-EVO, so it looks safe — our inference, not a vendor statement
Affected range stops below 21.1-EVO*, so it looks safe — our inference, not a vendor statement
Affected range stops below 21.2R3-EVO, so it looks safe — our inference, not a vendor statement
Affected range stops below 21.3R2-EVO, so it looks safe — our inference, not a vendor statement

Remediation

No guide yet

No remediation guidance has been written for this CVE yet. What the record does show:

Patch and advisory references

References (1)

SSVC — Action Prioritization

SSVCNo known exploitNot automatableTotal impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

7.3HIGHjuniper
Attack Vector
LOCAL
Complexity
LOW
Privileges
LOW
User Interaction
REQUIRED
Scope
UNCHANGED
Confidentiality
HIGH
Integrity
HIGH
Availability
HIGH
Vector?

Quick Info

StatusMODIFIED
CWE
CWE-732

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card