CVE-2022-22233

Junos OS and Junos OS Evolved: In an SR to LDP interworking scenario, with SRMS, when a specific low privileged command is issued on an ABR rpd will crash

MEDIUM
5.5
CVSS Score
Published: October 18, 2022 at 02:46 AM UTC
Updated: June 17, 2026 at 04:28 AM UTC
3 products affected across 2 vendorsJunosJunos OS EvolvedJunos OS Evolved

Using Junos OS by Juniper Networks?

Get instant alerts when new vulnerabilities affect Junos OS - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
MEDIUM5.5
Exploit prediction
EPSS 0.2%
SSVC
No known exploit

Description

An Unchecked Return Value to NULL Pointer Dereference vulnerability in Routing Protocol Daemon (rpd) of Juniper Networks Junos OS and Junos OS Evolved allows a locally authenticated attacker with low privileges to cause a Denial of Service (DoS). In Segment Routing (SR) to Label Distribution Protocol (LDP) interworking scenario, configured with Segment Routing Mapping Server (SRMS) at any node, when an Area Border Router (ABR) leaks the SRMS entries having "S" flag set from IS-IS Level 2 to Level 1, an rpd core might be observed when a specific low privileged CLI command is issued. This issue affects: Juniper Networks Junos OS 21.4 versions prior to 21.4R1-S2, 21.4R2-S1, 21.4R3; 22.1 versions prior to 22.1R2. Juniper Networks Junos OS Evolved 21.4-EVO versions prior to 21.4R1-S2-EVO, 21.4R2-S1-EVO, 21.4R3-EVO; 22.1-EVO versions prior to 22.1R2-EVO. This issue does not affect: Juniper Networks Junos OS versions prior to 21.4R1. Juniper Networks Junos OS Evolved versions prior to 21.4R1-EVO.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

21.4 ≤ v < 21.4R1-S2, 21.4R2-S1, 21.4R322.1 ≤ v < 22.1R221.421.4 r121.4 r1-s121.4 r222.122.1 r122.1 r1-s1
Vendor states this is fixed in 21.4R1 (unaffected)
Affected range stops below 21.4R1-S2, 21.4R2-S1, 21.4R3, so it looks safe — our inference, not a vendor statement
Affected range stops below 22.1R2, so it looks safe — our inference, not a vendor statement
21.4-EVO ≤ v < 21.4R1-S2-EVO, 21.4R2-S1-EVO, 21.4R3-EVO22.1-EVO ≤ v < 22.1R2-EVO21.4-EVO22.1-EVO
Vendor states this is fixed in 21.4R1-EVO (unaffected)
Affected range stops below 21.4R1-S2-EVO, 21.4R2-S1-EVO, 21.4R3-EVO, so it looks safe — our inference, not a vendor statement
Affected range stops below 22.1R2-EVO, so it looks safe — our inference, not a vendor statement

Remediation

No guide yet

No remediation guidance has been written for this CVE yet. What the record does show:

Patch and advisory references

References (1)

SSVC — Action Prioritization

SSVCNo known exploitNot automatablePartial impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

5.5MEDIUMjuniper
Attack Vector
LOCAL
Complexity
LOW
Privileges
LOW
User Interaction
NONE
Scope
UNCHANGED
Confidentiality
NONE
Integrity
NONE
Availability
HIGH
Vector?

Quick Info

StatusMODIFIED
CWE
CWE-690CWE-252

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card