CVE-2022-22220

Junos OS and Junos OS Evolved: Due to a race condition the rpd process can crash upon receipt of a BGP update message containing flow spec route

MEDIUM
5.9
CVSS Score
Published: October 18, 2022 at 02:46 AM UTC
Updated: June 17, 2026 at 04:28 AM UTC
3 products affected across 2 vendorsJunosJunos OS EvolvedJunos OS Evolved

Using Junos OS by Juniper Networks?

Get instant alerts when new vulnerabilities affect Junos OS - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
MEDIUM5.9
Exploit prediction
EPSS 0.5%
SSVC
No known exploit

Description

A Time-of-check Time-of-use (TOCTOU) Race Condition vulnerability in Routing Protocol Daemon (rpd) of Juniper Networks Junos OS, Junos OS Evolved allows a network-based unauthenticated attacker to cause a Denial of Service (DoS). When a BGP flow route with redirect IP extended community is received, and the reachability to the next-hop of the corresponding redirect IP is flapping, the rpd process might crash. Whether the crash occurs depends on the timing of the internally processing of these two events and is outside the attackers control. Please note that this issue also affects Route-Reflectors unless 'routing-options flow firewall-install-disable' is configured. This issue affects: Juniper Networks Junos OS: 18.4 versions prior to 18.4R2-S10, 18.4R3-S10; 19.1 versions prior to 19.1R3-S7; 19.2 versions prior to 19.2R1-S8, 19.2R3-S4; 19.4 versions prior to 19.4R3-S8; 20.2 versions prior to 20.2R3-S3; 20.3 versions prior to 20.3R3-S2; 20.4 versions prior to 20.4R3; 21.1 versions prior to 21.1R2. Juniper Networks Junos OS Evolved: All versions prior to 20.4R2-EVO; 21.1-EVO versions prior to 21.1R2-EVO. This issue does not affect Juniper Networks Junos OS versions prior to 18.4R1.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

Affected range stops below 20.4, so it looks safe — our inference, not a vendor statement
Affected range stops below 18.4, so it looks safe — our inference, not a vendor statement
Vendor states this is fixed in 18.4R1 (unaffected)
Affected range stops below 18.4R2-S10, 18.4R3-S10, so it looks safe — our inference, not a vendor statement
Affected range stops below 19.1R3-S7, so it looks safe — our inference, not a vendor statement
Affected range stops below 19.2R1-S8, 19.2R3-S4, so it looks safe — our inference, not a vendor statement
Affected range stops below 19.4R3-S8, so it looks safe — our inference, not a vendor statement
Affected range stops below 20.2R3-S3, so it looks safe — our inference, not a vendor statement
Affected range stops below 20.3R3-S2, so it looks safe — our inference, not a vendor statement
Affected range stops below 20.4R3, so it looks safe — our inference, not a vendor statement
Affected range stops below 21.1R2, so it looks safe — our inference, not a vendor statement
v < 20.4R2-EVO21.1-EVO ≤ v < 21.1R2-EVO21.1-EVO
Affected range stops below 20.4R2-EVO, so it looks safe — our inference, not a vendor statement
Affected range stops below 21.1R2-EVO, so it looks safe — our inference, not a vendor statement

Remediation

No guide yet

No remediation guidance has been written for this CVE yet. What the record does show:

Patch and advisory references

References (1)

SSVC — Action Prioritization

SSVCNo known exploitNot automatablePartial impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

5.9MEDIUMjuniper
Attack Vector
NETWORK
Complexity
HIGH
Privileges
NONE
User Interaction
NONE
Scope
UNCHANGED
Confidentiality
NONE
Integrity
NONE
Availability
HIGH
Vector?

Quick Info

StatusMODIFIED
CWE
CWE-367

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card