CVE-2022-22219

Junos OS and Junos OS Evolved: RPD core upon receipt of a specific EVPN route by a BGP route reflector in an EVPN environment

MEDIUM
5.9
CVSS Score
Published: October 18, 2022 at 02:46 AM UTC
Updated: June 17, 2026 at 04:28 AM UTC
3 products affected across 2 vendorsJunosJunos OS EvolvedJunos OS Evolved

Using Junos OS by Juniper Networks?

Get instant alerts when new vulnerabilities affect Junos OS - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
MEDIUM5.9
Exploit prediction
EPSS 0.7%
SSVC
No known exploit

Description

Due to the Improper Handling of an Unexpected Data Type in the processing of EVPN routes on Juniper Networks Junos OS and Junos OS Evolved, an attacker in direct control of a BGP client connected to a route reflector, or via a machine in the middle (MITM) attack, can send a specific EVPN route contained within a BGP Update, triggering a routing protocol daemon (RPD) crash, leading to a Denial of Service (DoS) condition. Continued receipt and processing of these specific EVPN routes could create a sustained Denial of Service (DoS) condition. This issue only occurs on BGP route reflectors, only within a BGP EVPN multicast environment, and only when one or more BGP clients have 'leave-sync-route-oldstyle' enabled. This issue affects: Juniper Networks Junos OS 21.3 versions prior to 21.3R3-S2; 21.4 versions prior to 21.4R2-S2, 21.4R3; 22.1 versions prior to 22.1R1-S2, 22.1R3; 22.2 versions prior to 22.2R2. Juniper Networks Junos OS Evolved 21.3 version 21.3R1-EVO and later versions prior to 21.4R3-EVO; 22.1 versions prior to 22.1R1-S2-EVO, 22.1R3-EVO; 22.2 versions prior to 22.2R2-EVO. This issue does not affect: Juniper Networks Junos OS versions prior to 21.3R1. Juniper Networks Junos OS Evolved versions prior to 21.3R1-EVO.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

Vendor states this is fixed in 21.3R1 (unaffected)
Affected range stops below 21.3R3-S2, so it looks safe — our inference, not a vendor statement
Affected range stops below 21.4R2-S2, 21.4R3, so it looks safe — our inference, not a vendor statement
Affected range stops below 22.1R1-S2, 22.1R3, so it looks safe — our inference, not a vendor statement
Affected range stops below 22.2R2, so it looks safe — our inference, not a vendor statement
21.3R1-EVO ≤ v < 21.3*21.4 ≤ v < 21.4R3-EVO22.1 ≤ v < 22.1R1-S2-EVO, 22.1R3-EVO22.2 ≤ v < 22.2R2-EVO21.3R1-EVO21.422.122.2
Affected range stops below 21.3*, so it looks safe — our inference, not a vendor statement
Vendor states this is fixed in 21.3R1-EVO (unaffected)
Affected range stops below 21.4R3-EVO, so it looks safe — our inference, not a vendor statement
Affected range stops below 22.1R1-S2-EVO, 22.1R3-EVO, so it looks safe — our inference, not a vendor statement
Affected range stops below 22.2R2-EVO, so it looks safe — our inference, not a vendor statement

Remediation

No guide yet

No remediation guidance has been written for this CVE yet. What the record does show:

SSVC — Action Prioritization

SSVCNo known exploitNot automatablePartial impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

5.9MEDIUMjuniper
Attack Vector
NETWORK
Complexity
HIGH
Privileges
NONE
User Interaction
NONE
Scope
UNCHANGED
Confidentiality
NONE
Integrity
NONE
Availability
HIGH
Vector?

Quick Info

StatusMODIFIED
CWE
CWE-241NVD-CWE-Other

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card