CVE-2022-22213

Junos OS and Junos OS Evolved: Denial of Service (DoS) vulnerability in RPD upon receipt of specific BGP update

MEDIUM
5.9
CVSS Score
Published: July 20, 2022 at 02:15 PM UTC
Updated: June 17, 2026 at 04:28 AM UTC
3 products affected across 2 vendorsJunosJunos OS EvolvedJunos OS Evolved

Using Junos OS by Juniper Networks?

Get instant alerts when new vulnerabilities affect Junos OS - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
MEDIUM5.9
Exploit prediction
EPSS 0.7%

Description

A vulnerability in Handling of Undefined Values in the routing protocol daemon (RPD) process of Juniper Networks Junos OS and Junos OS Evolved may allow an unauthenticated network-based attacker to crash the RPD process by sending a specific BGP update while the system is under heavy load, leading to a Denial of Service (DoS). Continued receipt and processing of this packet will create a sustained Denial of Service (DoS) condition. Malicious exploitation of this issue requires a very specific combination of load, timing, and configuration of the vulnerable system which is beyond the direct control of the attacker. Internal reproduction has only been possible through artificially created load and specially instrumented source code. Systems are only vulnerable to this issue if BGP multipath is enabled. Routers not configured for BGP multipath are not vulnerable to this issue. This issue affects: Juniper Networks Junos OS: 21.1 versions prior to 21.1R3-S1; 21.2 versions prior to 21.2R2-S2, 21.2R3; 21.3 versions prior to 21.3R2, 21.3R3; 21.4 versions prior to 21.4R1-S1, 21.4R2. Juniper Networks Junos OS Evolved: 21.1 versions prior to 21.1R3-S1-EVO; 21.2 version 21.2R1-EVO and later versions; 21.3 versions prior to 21.3R3-EVO; 21.4 versions prior to 21.4R1-S1-EVO, 21.4R2-EVO. This issue does not affect: Juniper Networks Junos OS versions prior to 21.1. Juniper Networks Junos OS Evolved versions prior to 21.1-EVO.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

Vendor states this is fixed in 21.1 (unaffected)
Affected range stops below 21.1R3-S1, so it looks safe — our inference, not a vendor statement
Affected range stops below 21.2R2-S2, 21.2R3, so it looks safe — our inference, not a vendor statement
Affected range stops below 21.3R2, 21.3R3, so it looks safe — our inference, not a vendor statement
Affected range stops below 21.4R1-S1, 21.4R2, so it looks safe — our inference, not a vendor statement
21.1 ≤ v < 21.1R3-S1-EVO21.2R1-EVO ≤ v < 21.2*21.3 ≤ v < 21.3R3-EVO21.4 ≤ v < 21.4R1-S1-EVO, 21.4R2-EVO21.121.2R1-EVO21.321.4
Vendor states this is fixed in 21.1-EVO (unaffected)
Affected range stops below 21.1R3-S1-EVO, so it looks safe — our inference, not a vendor statement
Affected range stops below 21.2*, so it looks safe — our inference, not a vendor statement
Affected range stops below 21.3R3-EVO, so it looks safe — our inference, not a vendor statement
Affected range stops below 21.4R1-S1-EVO, 21.4R2-EVO, so it looks safe — our inference, not a vendor statement

Remediation

No guide yet

No remediation guidance has been written for this CVE yet. What the record does show:

Patch and advisory references

References (1)

x_refsource_CONFIRMVendor Advisory
https://kb.juniper.net/JSA69717

CVSS

5.9MEDIUMjuniper
Attack Vector
NETWORK
Complexity
HIGH
Privileges
NONE
User Interaction
NONE
Scope
UNCHANGED
Confidentiality
NONE
Integrity
NONE
Availability
HIGH
Vector?

Quick Info

StatusMODIFIED
CWE
CWE-232NVD-CWE-Other

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card