CVE-2022-22206

Junos OS: SRX series: The PFE will crash when specific traffic is scanned by Enhanced Web Filtering safe-search

HIGH
7.5
CVSS Score
Published: July 20, 2022 at 02:13 PM UTC
Updated: June 17, 2026 at 04:28 AM UTC
28 products affected across 2 vendorsJunosSRX5600SRX5800

Using Junos OS by Juniper Networks?

Get instant alerts when new vulnerabilities affect Junos OS - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
HIGH7.5
Exploit prediction
EPSS 0.8%

Description

A Buffer Overflow vulnerability in the PFE of Juniper Networks Junos OS on SRX series allows an unauthenticated network based attacker to cause a Denial of Service (DoS). The PFE will crash when specific traffic is scanned by Enhanced Web Filtering safe-search feature of UTM (Unified Threat management). Continued receipt of this specific traffic will create a sustained Denial of Service (DoS) condition. This issue affects Juniper Networks Junos OS: 20.2 versions prior to 20.2R3-S4 on SRX Series; 20.3 versions prior to 20.3R3-S3 on SRX Series; 20.4 versions prior to 20.4R3-S3 on SRX Series; 21.1 versions prior to 21.1R3-S1 on SRX Series; 21.2 versions prior to 21.2R2-S2, 21.2R3 on SRX Series; 21.3 versions prior to 21.3R2 on SRX Series; 21.4 versions prior to 21.4R2 on SRX Series. This issue does not affect Juniper Networks Junos OS versions prior to 20.2R1.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

Vendor states this is fixed in 20.2R1 (unaffected)
Affected range stops below 20.2R3-S4, so it looks safe — our inference, not a vendor statement
Affected range stops below 20.3R3-S3, so it looks safe — our inference, not a vendor statement
Affected range stops below 20.4R3-S3, so it looks safe — our inference, not a vendor statement
Affected range stops below 21.1R3-S1, so it looks safe — our inference, not a vendor statement
Affected range stops below 21.2R2-S2, 21.2R3, so it looks safe — our inference, not a vendor statement
Affected range stops below 21.3R2, so it looks safe — our inference, not a vendor statement
Affected range stops below 21.4R2, so it looks safe — our inference, not a vendor statement
juniper-srx100 (environment) · juniper-srx110 (environment) · juniper-srx1400 (environment) · juniper-srx1500 (environment) · juniper-srx210 (environment) · juniper-srx220 (environment) · juniper-srx240 (environment) · juniper-srx240h2 (environment) · juniper-srx300 (environment) · juniper-srx320 (environment) · juniper-srx340 (environment) · juniper-srx3400 (environment) · juniper-srx345 (environment) · juniper-srx3600 (environment) · juniper-srx380 (environment) · juniper-srx4000 (environment) · juniper-srx4100 (environment) · juniper-srx4200 (environment) · juniper-srx4600 (environment) · juniper-srx5000 (environment) · juniper-srx5400 (environment) · juniper-srx550 (environment) · juniper-srx550-hm (environment) · juniper-srx550m (environment) · juniper-srx5600 (environment) · juniper-srx5800 (environment) · juniper-srx650 (environment)
All versions
All versions
All versions
All versions
All versions
All versions
All versions
All versions
All versions

Remediation

No guide yet

No remediation guidance has been written for this CVE yet. What the record does show:

Patch and advisory references

References (1)

x_refsource_CONFIRMMailing ListMitigationVendor Advisory
https://kb.juniper.net/JSA69710

CVSS

7.5HIGHjuniper
Attack Vector
NETWORK
Complexity
LOW
Privileges
NONE
User Interaction
NONE
Scope
UNCHANGED
Confidentiality
NONE
Integrity
NONE
Availability
HIGH
Vector?

Quick Info

StatusMODIFIED
CWE
CWE-120

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card