CVE-2022-22196

Junos OS and Junos OS Evolved: The rpd CPU spikes to 100% after a malformed ISIS TLV has been received

MEDIUM
6.5
CVSS Score
Published: April 14, 2022 at 03:50 PM UTC
Updated: June 17, 2026 at 04:27 AM UTC
3 products affected across 2 vendorsJunosJunos OS EvolvedJunos OS Evolved

Using Junos OS by Juniper Networks?

Get instant alerts when new vulnerabilities affect Junos OS - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
MEDIUM6.5
Exploit prediction
EPSS 0.4%

Description

An Improper Check for Unusual or Exceptional Conditions vulnerability in the Routing Protocol Daemon (rpd) of Juniper Networks Junos OS and Junos OS Evolved allows an adjacent, unauthenticated attacker with an established ISIS adjacency to cause a Denial of Service (DoS). The rpd CPU spikes to 100% after a malformed ISIS TLV has been received which will lead to processing issues of routing updates and in turn traffic impact. This issue affects: Juniper Networks Junos OS 19.3 versions prior to 19.3R3-S4; 19.4 versions prior to 19.4R2-S6, 19.4R3-S6; 20.1 versions prior to 20.1R3-S2; 20.2 versions prior to 20.2R3-S3; 20.3 versions prior to 20.3R3-S1; 20.4 versions prior to 20.4R3; 21.1 versions prior to 21.1R3; 21.2 versions prior to 21.2R2. Juniper Networks Junos OS Evolved All versions prior to 20.4R3-S3-EVO; 21.2 versions prior to 21.2R2-EVO. This issue does not affect Juniper Networks Junos OS versions prior to 19.3R1.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

Affected range stops below 20.4, so it looks safe — our inference, not a vendor statement
Vendor states this is fixed in 19.3R1 (unaffected)
Affected range stops below 19.3R3-S4, so it looks safe — our inference, not a vendor statement
Affected range stops below 19.4R2-S6, 19.4R3-S6, so it looks safe — our inference, not a vendor statement
Affected range stops below 20.1R3-S2, so it looks safe — our inference, not a vendor statement
Affected range stops below 20.2R3-S3, so it looks safe — our inference, not a vendor statement
Affected range stops below 20.3R3-S1, so it looks safe — our inference, not a vendor statement
Affected range stops below 20.4R3, so it looks safe — our inference, not a vendor statement
Affected range stops below 21.1R3, so it looks safe — our inference, not a vendor statement
Affected range stops below 21.2R2, so it looks safe — our inference, not a vendor statement
v < 20.4R3-S3-EVO21.2 ≤ v < 21.2R2-EVO21.2
Affected range stops below 20.4R3-S3-EVO, so it looks safe — our inference, not a vendor statement
Affected range stops below 21.2R2-EVO, so it looks safe — our inference, not a vendor statement

Remediation

No guide yet

No remediation guidance has been written for this CVE yet. What the record does show:

Patch and advisory references

References (1)

x_refsource_CONFIRMVendor Advisory
https://kb.juniper.net/JSA69509

CVSS

6.5MEDIUMjuniper
Attack Vector
ADJACENT_NETWORK
Complexity
LOW
Privileges
NONE
User Interaction
NONE
Scope
UNCHANGED
Confidentiality
NONE
Integrity
NONE
Availability
HIGH
Vector?

Quick Info

StatusMODIFIED
CWE
CWE-754

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card