CVE-2022-22193

Junos OS and Junos OS Evolved: In a BGP rib-sharding scenario when a certain CLI command is executed the rpd process might crash

MEDIUM
5.5
CVSS Score
Published: April 14, 2022 at 03:50 PM UTC
Updated: June 17, 2026 at 04:27 AM UTC
3 products affected across 2 vendorsJunosJunos OS EvolvedJunos OS Evolved

Using Junos OS by Juniper Networks?

Get instant alerts when new vulnerabilities affect Junos OS - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
MEDIUM5.5
Exploit prediction
EPSS 0.2%

Description

An Improper Handling of Unexpected Data Type vulnerability in the Routing Protocol Daemon (rpd) of Juniper Networks Junos OS and Junos OS Evolved allows a locally authenticated attacker with low privileges to cause a Denial of Service (DoS). Continued execution of this command might cause a sustained Denial of Service condition. If BGP rib sharding is configured and a certain CLI command is executed the rpd process can crash. During the rpd crash and restart, the routing protocols might be impacted and traffic disruption might be seen due to the loss of routing information. This issue affects: Juniper Networks Junos OS 20.3 versions prior to 20.3R3-S1; 20.4 versions prior to 20.4R3; 21.1 versions prior to 21.1R3; 21.2 versions prior to 21.2R2. Juniper Networks Junos OS Evolved 20.4 versions prior to 20.4R3-EVO; 21.1 versions prior to 21.1R3-EVO; 21.2 versions prior to 21.2R2-EVO. This issue does not affect: Juniper Networks Junos OS versions prior to 20.3R1. Juniper Networks Junos OS Evolved versions prior to 20.3R1-EVO.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

Vendor states this is fixed in 20.3R1 (unaffected)
Affected range stops below 20.3R3-S1, so it looks safe — our inference, not a vendor statement
Affected range stops below 20.4R3, so it looks safe — our inference, not a vendor statement
Affected range stops below 21.1R3, so it looks safe — our inference, not a vendor statement
Affected range stops below 21.2R2, so it looks safe — our inference, not a vendor statement
20.3R1-EVO ≤ v < 20.3*20.4 ≤ v < 20.4R3-EVO21.1 ≤ v < 21.1R3-EVO21.2 ≤ v < 21.2R2-EVO20.3R1-EVO20.421.121.2
Affected range stops below 20.3*, so it looks safe — our inference, not a vendor statement
Vendor states this is fixed in 20.3R1-EVO (unaffected)
Affected range stops below 20.4R3-EVO, so it looks safe — our inference, not a vendor statement
Affected range stops below 21.1R3-EVO, so it looks safe — our inference, not a vendor statement
Affected range stops below 21.2R2-EVO, so it looks safe — our inference, not a vendor statement

Remediation

No guide yet

No remediation guidance has been written for this CVE yet. What the record does show:

Patch and advisory references

References (1)

x_refsource_CONFIRMVendor Advisory
https://kb.juniper.net/JSA69503

CVSS

5.5MEDIUMjuniper
Attack Vector
LOCAL
Complexity
LOW
Privileges
LOW
User Interaction
NONE
Scope
UNCHANGED
Confidentiality
NONE
Integrity
NONE
Availability
HIGH
Vector?

Quick Info

StatusMODIFIED
CWE
CWE-241

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card