CVE-2022-2196

Speculative execution attacks in KVM VMX

HIGH
8.8
CVSS Score
Published: January 9, 2023 at 10:59 AM UTC
Updated: August 7, 2026 at 07:17 PM UTC
2 products affected across 2 vendorsLinux KernelDebian Linux

Using Linux Kernel by Linux?

Get instant alerts when new vulnerabilities affect Linux Kernel - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
HIGH8.8
Exploit prediction
EPSS 0.4%
SSVC
No known exploit

Description

A regression exists in the Linux Kernel within KVM: nVMX that allowed for speculative execution attacks. L2 can carry out Spectre v2 attacks on L1 due to L1 thinking it doesn't need retpolines or IBPB after running L2 due to KVM (L0) advertising eIBRS support to L1. An attacker at L2 with code execution can execute code on an indirect branch on the host machine. We recommend upgrading to Kernel 6.2 or past commit 2e7eab81425a

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

5.11 ≤ v < 5.15.965.11.0 ≤ v < 5.15.965.16 ≤ v < 6.1.145.16.0 ≤ v < 6.1.145.4.47 ≤ v < 5.4.2335.6.19 ≤ v < 5.75.6.19 ≤ v < 5.7.05.7.3 ≤ v < 5.10.1705.7.3 ≤ v < 5.8.05.8.0 ≤ v < 5.10.1702a3868d18fe639363f1cea6e6d7914513198e435.11.05.16.05.4.475.6.195.7.35.8.05c911beff20aa8639e7a1f28988736c13e03ed5464b8f33b2e1e687d465b5cb382e7bec495f1e026e089a83fbc55b8057f332c00f125acaa02b08ef7
Vendor states this is fixed in 1b0cafaae8884726c597caded50af185ffc13349 (fixed)
Vendor states this is fixed in 2e7eab81425ad6c875f2ed47c0ce01e78afc38a5 (fixed)
Vendor states this is fixed in 63fada296062e91ad9f871970d4e7f19e21a6a15 (fixed)
Vendor states this is fixed in 6b539a7dbb49250f92515c2ba60aea239efc9e35 (fixed)
Vendor states this is fixed in f93a1a5bdcdd122aae0a3eab7a52c15b71fb725b (fixed)
Affected range stops below 5.10.170, so it looks safe — our inference, not a vendor statement
Affected range stops below 5.15.96, so it looks safe — our inference, not a vendor statement
Affected range stops below 5.4.233, so it looks safe — our inference, not a vendor statement
Affected range stops below 5.7, so it looks safe — our inference, not a vendor statement
Affected range stops below 5.7.0, so it looks safe — our inference, not a vendor statement
Affected range stops below 5.8.0, so it looks safe — our inference, not a vendor statement
Affected range stops below 6.1.14, so it looks safe — our inference, not a vendor statement
Vendor states this is fixed in 6.2.0 (unaffected)

Remediation

No guide yet

No remediation guidance has been written for this CVE yet. What the record does show:

SSVC — Action Prioritization

SSVCNo known exploitNot automatableTotal impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

Attack Vector
LOCAL
Complexity
LOW
Privileges
LOW
User Interaction
NONE
Scope
CHANGED
Confidentiality
HIGH
Integrity
HIGH
Availability
HIGH
Vector?

Quick Info

StatusMODIFIED
CWE
CWE-1188

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card