CVE-2022-21661

SQL injection in WordPress

HIGH
7.5
CVSS Score
Published: January 6, 2022 at 10:50 PM UTC
Updated: June 17, 2026 at 04:26 AM UTC
3 products affected across 3 vendorsDebian LinuxFedoraWordPress

Using wordpress-develop by WordPress?

Get instant alerts when new vulnerabilities affect wordpress-develop - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
HIGH7.5
Exploit prediction
EPSS 98%
SSVC
PoC

Description

WordPress is a free and open-source content management system written in PHP and paired with a MariaDB database. Due to improper sanitization in WP_Query, there can be cases where SQL injection is possible through plugins or themes that use it in a certain way. This has been patched in WordPress version 5.8.3. Older affected versions are also fixed via security release, that go back till 3.7.37. We strongly recommend that you keep auto-updates enabled. There are no known workarounds for this vulnerability.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

v < 5.8.33.7 ≤ v < 3.7.373.8 ≤ v < 3.8.373.9 ≤ v < 3.9.354.0 ≤ v < 4.0.344.1 ≤ v < 4.1.344.2 ≤ v < 4.2.314.3 ≤ v < 4.3.274.4 ≤ v < 4.4.264.5 ≤ v < 4.5.254.6 ≤ v < 4.6.224.7 ≤ v < 4.7.224.8 ≤ v < 4.8.184.9 ≤ v < 4.9.195.0 ≤ v < 5.0.155.1 ≤ v < 5.1.125.2 ≤ v < 5.2.145.3 ≤ v < 5.3.115.4 ≤ v < 5.4.95.5 ≤ v < 5.5.85.6 ≤ v < 5.6.75.7 ≤ v < 5.7.55.8 ≤ v < 5.8.3
Affected range stops below 3.7.37, so it looks safe — our inference, not a vendor statement
Affected range stops below 3.8.37, so it looks safe — our inference, not a vendor statement
Affected range stops below 3.9.35, so it looks safe — our inference, not a vendor statement
Affected range stops below 4.0.34, so it looks safe — our inference, not a vendor statement
Affected range stops below 4.1.34, so it looks safe — our inference, not a vendor statement
Affected range stops below 4.2.31, so it looks safe — our inference, not a vendor statement
Affected range stops below 4.3.27, so it looks safe — our inference, not a vendor statement
Affected range stops below 4.4.26, so it looks safe — our inference, not a vendor statement
Affected range stops below 4.5.25, so it looks safe — our inference, not a vendor statement
Affected range stops below 4.6.22, so it looks safe — our inference, not a vendor statement
Affected range stops below 4.7.22, so it looks safe — our inference, not a vendor statement
Affected range stops below 4.8.18, so it looks safe — our inference, not a vendor statement
Affected range stops below 4.9.19, so it looks safe — our inference, not a vendor statement
Affected range stops below 5.0.15, so it looks safe — our inference, not a vendor statement
Affected range stops below 5.1.12, so it looks safe — our inference, not a vendor statement
Affected range stops below 5.2.14, so it looks safe — our inference, not a vendor statement
Affected range stops below 5.3.11, so it looks safe — our inference, not a vendor statement
Affected range stops below 5.4.9, so it looks safe — our inference, not a vendor statement
Affected range stops below 5.5.8, so it looks safe — our inference, not a vendor statement
Affected range stops below 5.6.7, so it looks safe — our inference, not a vendor statement
Affected range stops below 5.7.5, so it looks safe — our inference, not a vendor statement
Affected range stops below 5.8.3, so it looks safe — our inference, not a vendor statement

SSVC — Action Prioritization

SSVCPoCNot automatableTotal impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

Attack Vector
NETWORK
Complexity
LOW
Privileges
NONE
User Interaction
NONE
Scope
UNCHANGED
Confidentiality
HIGH
Integrity
NONE
Availability
NONE
Vector?

Quick Info

StatusANALYZED
CWE
CWE-89

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card