CVE-2022-21658

Race condition in std::fs::remove_dir_all in rustlang

MEDIUM
6.3
CVSS Score
Published: January 20, 2022 at 12:00 AM UTC
Updated: June 17, 2026 at 04:26 AM UTC
7 products affected across 3 vendorsmacOSFedoraiPhone OS

Using rust by rust-lang?

Get instant alerts when new vulnerabilities affect rust - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
MEDIUM6.3
Exploit prediction
EPSS 1%
SSVC
PoC

Description

Rust is a multi-paradigm, general-purpose programming language designed for performance and safety, especially safe concurrency. The Rust Security Response WG was notified that the `std::fs::remove_dir_all` standard library function is vulnerable a race condition enabling symlink following (CWE-363). An attacker could use this security issue to trick a privileged program into deleting files and directories the attacker couldn't otherwise access or delete. Rust 1.0.0 through Rust 1.58.0 is affected by this vulnerability with 1.58.1 containing a patch. Note that the following build targets don't have usable APIs to properly mitigate the attack, and are thus still vulnerable even with a patched toolchain: macOS before version 10.10 (Yosemite) and REDOX. We recommend everyone to update to Rust 1.58.1 as soon as possible, especially people developing programs expected to run in privileged contexts (including system daemons and setuid binaries), as those have the highest risk of being affected by this. Note that adding checks in your codebase before calling remove_dir_all will not mitigate the vulnerability, as they would also be vulnerable to race conditions like remove_dir_all itself. The existing mitigation is working as intended outside of race conditions.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

v < 15.4
Affected range stops below 15.4, so it looks safe — our inference, not a vendor statement
v < 15.4
Affected range stops below 15.4, so it looks safe — our inference, not a vendor statement
12.0.0 ≤ v < 12.3
Affected range stops below 12.3, so it looks safe — our inference, not a vendor statement
v < 15.4
Affected range stops below 15.4, so it looks safe — our inference, not a vendor statement
v < 8.5
Affected range stops below 8.5, so it looks safe — our inference, not a vendor statement
v < 1.58.11.0.0 ≤ v ≤ 1.58.0
Affected range stops below 1.58.1, so it looks safe — our inference, not a vendor statement

SSVC — Action Prioritization

SSVCPoCNot automatablePartial impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

Attack Vector
LOCAL
Complexity
HIGH
Privileges
LOW
User Interaction
NONE
Scope
UNCHANGED
Confidentiality
NONE
Integrity
HIGH
Availability
HIGH
Vector?

Quick Info

StatusMODIFIED
CWE
CWE-363CWE-367

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card