CVE-2022-1941

Out of Memory issue in ProtocolBuffers for cpp and python

HIGH
7.5
CVSS Score
Published: September 22, 2022 at 12:00 AM UTC
Updated: June 17, 2026 at 04:23 AM UTC
4 products affected across 3 vendorsDebian LinuxFedoraProtobuf Python

Using protobuf-cpp by Google LLC?

Get instant alerts when new vulnerabilities affect protobuf-cpp - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
HIGH7.5
Exploit prediction
EPSS 2%
SSVC
No known exploit

Description

A parsing vulnerability for the MessageSet type in the ProtocolBuffers versions prior to and including 3.16.1, 3.17.3, 3.18.2, 3.19.4, 3.20.1 and 3.21.5 for protobuf-cpp, and versions prior to and including 3.16.1, 3.17.3, 3.18.2, 3.19.4, 3.20.1 and 4.21.5 for protobuf-python can lead to out of memory failures. A specially crafted message with multiple key-value per elements creates parsing issues, and can lead to a Denial of Service against services receiving unsanitized input. We recommend upgrading to versions 3.18.3, 3.19.5, 3.20.2, 3.21.6 for protobuf-cpp and 3.18.3, 3.19.5, 3.20.2, 4.21.6 for protobuf-python. Versions for 3.16 and 3.17 are no longer updated.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

v ≤ 3.16.1v ≤ 3.17.3v ≤ 3.18.2v ≤ 3.19.4v ≤ 3.20.1v ≤ 3.21.5v < 3.18.33.19.0 ≤ v < 3.19.53.20.0 ≤ v < 3.20.23.21.0 ≤ v < 3.21.63.19.03.20.03.21.0
Affected range stops below 3.18.3, so it looks safe — our inference, not a vendor statement
Affected range stops below 3.19.5, so it looks safe — our inference, not a vendor statement
Affected range stops below 3.20.2, so it looks safe — our inference, not a vendor statement
Affected range stops below 3.21.6, so it looks safe — our inference, not a vendor statement
v ≤ 3.16.1v ≤ 3.17.3v ≤ 3.18.2v ≤ 3.19.4v ≤ 3.20.1v ≤ 4.21.5v < 3.18.33.19.0 ≤ v < 3.19.53.20.0 ≤ v < 3.20.24.0.0 ≤ v < 4.21.63.19.03.20.04.0.0
Affected range stops below 3.18.3, so it looks safe — our inference, not a vendor statement
Affected range stops below 3.19.5, so it looks safe — our inference, not a vendor statement
Affected range stops below 3.20.2, so it looks safe — our inference, not a vendor statement
Affected range stops below 4.21.6, so it looks safe — our inference, not a vendor statement

SSVC — Action Prioritization

SSVCNo known exploitAutomatablePartial impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

7.5HIGHCISA-ADP
Attack Vector
NETWORK
Complexity
LOW
Privileges
NONE
User Interaction
NONE
Scope
UNCHANGED
Confidentiality
NONE
Integrity
NONE
Availability
HIGH
Vector?

Quick Info

StatusMODIFIED
CWE
CWE-1286NVD-CWE-Other

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card