CVE-2022-1552

HIGH
8.8
CVSS Score
Published: August 31, 2022 at 12:00 AM UTC
Updated: June 17, 2026 at 04:22 AM UTC
1 product affected across 1 vendorPostgreSQL

Using postgresql by N/A?

Get instant alerts when new vulnerabilities affect postgresql - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
HIGH8.8
Exploit prediction
EPSS 17%

Description

A flaw was found in PostgreSQL. There is an issue with incomplete efforts to operate safely when a privileged user is maintaining another user's objects. The Autovacuum, REINDEX, CREATE INDEX, REFRESH MATERIALIZED VIEW, CLUSTER, and pg_amcheck commands activated relevant protections too late or not at all during the process. This flaw allows an attacker with permission to create non-temporary objects in at least one schema to execute arbitrary SQL functions under a superuser identity.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

10.0 ≤ v < 10.2111.0 ≤ v < 11.1612.0 ≤ v < 12.1113.0 ≤ v < 13.714.0 ≤ v < 14.3
Affected range stops below 10.21, so it looks safe — our inference, not a vendor statement
Affected range stops below 11.16, so it looks safe — our inference, not a vendor statement
Affected range stops below 12.11, so it looks safe — our inference, not a vendor statement
Affected range stops below 13.7, so it looks safe — our inference, not a vendor statement
Vendor states this is fixed in 14.3 (unaffected)

CVSS

Attack Vector
NETWORK
Complexity
LOW
Privileges
LOW
User Interaction
NONE
Scope
UNCHANGED
Confidentiality
HIGH
Integrity
HIGH
Availability
HIGH
Vector?

Quick Info

StatusMODIFIED
CWE
CWE-459CWE-89

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card