CVE-2022-0757

Rapid7 Nexpose SQL Injection

HIGH
8.8
CVSS Score
Published: March 17, 2022 at 10:30 PM UTC
Updated: June 17, 2026 at 04:21 AM UTC
1 product affected across 1 vendorNexpose

Using Nexpose by Rapid7?

Get instant alerts when new vulnerabilities affect Nexpose - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
HIGH8.8
Exploit prediction
EPSS 1%

Description

Rapid7 Nexpose versions 6.6.93 and earlier are susceptible to an SQL Injection vulnerability, whereby valid search operators are not defined. This lack of validation can allow a logged-in, authenticated attacker to manipulate the "ANY" and "OR" operators in the SearchCriteria and inject SQL code. This issue was fixed in Rapid7 Nexpose version 6.6.129.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

v ≤ 6.6.93v < 6.6.93
Affected range stops below 6.6.93, so it looks safe — our inference, not a vendor statement

Remediation

No guide yet

No remediation guidance has been written for this CVE yet. What the record does show:

References (1)

x_refsource_CONFIRMRelease NotesVendor Advisory
https://docs.rapid7.com/release-notes/nexpose/20220302/

CVSS

Attack Vector
NETWORK
Complexity
LOW
Privileges
LOW
User Interaction
NONE
Scope
UNCHANGED
Confidentiality
HIGH
Integrity
HIGH
Availability
HIGH
Vector?

Quick Info

StatusMODIFIED
CWE
CWE-89

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card