CVE-2022-0677

Improper Handling of Length Parameter Inconsistency vulnerability in Bitdefender Update Server (VA-10144)

HIGH
7.5
CVSS Score
Published: April 7, 2022 at 06:21 PM UTC
Updated: June 17, 2026 at 04:21 AM UTC
3 products affected across 1 vendorGravityZoneEndpoint Security ToolsUpdate Server

Using Update Server by Bitdefender?

Get instant alerts when new vulnerabilities affect Update Server - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
HIGH7.5
Exploit prediction
EPSS 1%

Description

Improper Handling of Length Parameter Inconsistency vulnerability in the Update Server component of Bitdefender Endpoint Security Tools (in relay role), GravityZone (in Update Server role) allows an attacker to cause a Denial-of-Service. This issue affects: Bitdefender Update Server versions prior to 3.4.0.276. Bitdefender GravityZone versions prior to 26.4-1. Bitdefender Endpoint Security Tools for Linux versions prior to 6.2.21.171. Bitdefender Endpoint Security Tools for Windows versions prior to 7.4.1.111.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

v < 6.2.21.171v < 7.4.1.111
Affected range stops below 6.2.21.171, so it looks safe — our inference, not a vendor statement
Affected range stops below 7.4.1.111, so it looks safe — our inference, not a vendor statement
v < 26.4-1
Affected range stops below 26.4-1, so it looks safe — our inference, not a vendor statement
v < 3.4.0.276
Affected range stops below 3.4.0.276, so it looks safe — our inference, not a vendor statement

Remediation

No guide yet

No remediation guidance has been written for this CVE yet. What the record does show:

CVSS

7.5HIGHBitdefender
Attack Vector
NETWORK
Complexity
LOW
Privileges
NONE
User Interaction
NONE
Scope
UNCHANGED
Confidentiality
NONE
Integrity
NONE
Availability
HIGH
Vector?

Quick Info

StatusMODIFIED
CWE
CWE-130NVD-CWE-Other

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card