CVE-2022-0451

Auth bypass in Dark SDK

MEDIUM
6.5
CVSS Score
Published: February 18, 2022 at 01:35 PM UTC
Updated: June 17, 2026 at 04:20 AM UTC
1 product affected across 1 vendorDart Software Development Kit

Using Dart SDK by Google LLC?

Get instant alerts when new vulnerabilities affect Dart SDK - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
MEDIUM6.5
Exploit prediction
EPSS 1.0%
SSVC
No known exploit

Description

Dart SDK contains the HTTPClient in dart:io library whcih includes authorization headers when handling cross origin redirects. These headers may be explicitly set and contain sensitive information. By default, HttpClient handles redirection logic. If a request is sent to example.com with authorization header and it redirects to an attackers site, they might not expect attacker site to receive authorization header. We recommend updating the Dart SDK to version 2.16.0 or beyond.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

v < 2.16.0
Affected range stops below 2.16.0, so it looks safe — our inference, not a vendor statement

Remediation

No guide yet

No remediation guidance has been written for this CVE yet. What the record does show:

References (2)

x_refsource_MISCIssue TrackingPatchThird Party Advisory
https://dart-review.googlesource.com/c/sdk/+/229947

SSVC — Action Prioritization

SSVCNo known exploitNot automatablePartial impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

6.5MEDIUMGoogle
Attack Vector
NETWORK
Complexity
LOW
Privileges
LOW
User Interaction
NONE
Scope
UNCHANGED
Confidentiality
HIGH
Integrity
NONE
Availability
NONE
Vector?

Quick Info

StatusMODIFIED
CWE
CWE-305CWE-863

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card