CVE-2022-0024

PAN-OS: Improper Neutralization Vulnerability Leads to Unintended Program Execution During Configuration Commit

HIGH
7.2
CVSS Score
Published: May 11, 2022 at 04:30 PM UTC
Updated: June 17, 2026 at 04:19 AM UTC
1 product affected across 1 vendorPAN-OS

Using PAN-OS by Palo Alto Networks?

Get instant alerts when new vulnerabilities affect PAN-OS - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
HIGH7.2
Exploit prediction
EPSS 2%

Description

A vulnerability exists in Palo Alto Networks PAN-OS software that enables an authenticated network-based PAN-OS administrator to upload a specifically created configuration that disrupts system processes and potentially execute arbitrary code with root privileges when the configuration is committed on both hardware and virtual firewalls. This issue does not impact Panorama appliances or Prisma Access customers. This issue impacts: PAN-OS 8.1 versions earlier than PAN-OS 8.1.23; PAN-OS 9.0 versions earlier than PAN-OS 9.0.16; PAN-OS 9.1 versions earlier than PAN-OS 9.1.13; PAN-OS 10.0 versions earlier than PAN-OS 10.0.10; PAN-OS 10.1 versions earlier than PAN-OS 10.1.5.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

10.0 ≤ v < 10.0.1010.0.0 ≤ v < 10.0.1010.1 ≤ v < 10.1.510.1.0 ≤ v < 10.1.58.1 ≤ v < 8.1.238.1.0 ≤ v < 8.1.239.0 ≤ v < 9.0.169.0.0 ≤ v < 9.0.169.1 ≤ v < 9.1.139.1.0 ≤ v < 9.1.1310.010.18.19.09.1
Affected range stops below 10.0.10, so it looks safe — our inference, not a vendor statement
Affected range stops below 10.1.5, so it looks safe — our inference, not a vendor statement
Vendor states this is fixed in 10.2.0 (unaffected)
Affected range stops below 8.1.23, so it looks safe — our inference, not a vendor statement
Affected range stops below 9.0.16, so it looks safe — our inference, not a vendor statement
Affected range stops below 9.1.13, so it looks safe — our inference, not a vendor statement

Remediation

No guide yet

No remediation guidance has been written for this CVE yet. What the record does show:

References (1)

CVSS

7.2HIGHpalo_alto
Attack Vector
NETWORK
Complexity
LOW
Privileges
HIGH
User Interaction
NONE
Scope
UNCHANGED
Confidentiality
HIGH
Integrity
HIGH
Availability
HIGH
Vector?

Quick Info

StatusMODIFIED
CWE
CWE-138NVD-CWE-Other

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card