CVE-2021-43798

Grafana path traversal

HIGH
7.5
CVSS Score
Published: December 7, 2021 at 06:25 PM UTC
Updated: June 17, 2026 at 04:11 AM UTC
1 product affected across 1 vendorGrafana

Using grafana by grafana?

Get instant alerts when new vulnerabilities affect grafana - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
HIGH7.5
Exploitation
CISA KEV
Exploit prediction
EPSS 89%
SSVC
Active

Actively Exploited

CISA Known Exploited Vulnerabilities (KEV) Catalog

EPSS Score88.5%

EPSS (Exploit Prediction Scoring System) estimates a 88.5% chance this CVE is exploited in the wild within the next 30 days — higher than 100% of all CVEs. It complements CVSS: a high EPSS on a mid-severity CVE can still be urgent.

Grafana contains a path traversal vulnerability that could allow access to local files.

Required Action
Apply mitigations per vendor instructions, follow applicable BOD 22-01 guidance for cloud services, or discontinue use of the product if mitigations are unavailable.
Ransomware Use
Unknown
Added to KEV
Oct 9, 2025
Remediation Due
Oct 30, 2025
365 days overdue

Description

Grafana is an open-source platform for monitoring and observability. Grafana versions 8.0.0-beta1 through 8.3.0 (except for patched versions) iss vulnerable to directory traversal, allowing access to local files. The vulnerable URL path is: `<grafana_host_url>/public/plugins//`, where is the plugin ID for any installed plugin. At no time has Grafana Cloud been vulnerable. Users are advised to upgrade to patched versions 8.0.7, 8.1.8, 8.2.7, or 8.3.1. The GitHub Security Advisory contains more information about vulnerable URL paths, mitigation, and the disclosure timeline.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

v < 8.0.7v < 8.1.8v < 8.2.78.0.1 ≤ v < 8.0.78.1.0 ≤ v < 8.1.88.2.0 ≤ v < 8.2.78.0.0 beta18.0.0 beta28.0.0 beta38.3.0= 8.3.0
Affected range stops below 8.0.7, so it looks safe — our inference, not a vendor statement
Affected range stops below 8.1.8, so it looks safe — our inference, not a vendor statement
Affected range stops below 8.2.7, so it looks safe — our inference, not a vendor statement

SSVC — Action Prioritization

SSVCActiveAutomatablePartial impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

7.5HIGHGitHub_M
Attack Vector
NETWORK
Complexity
LOW
Privileges
NONE
User Interaction
NONE
Scope
UNCHANGED
Confidentiality
HIGH
Integrity
NONE
Availability
NONE
Vector?

Quick Info

StatusANALYZED
CWE
CWE-22

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card