CVE-2021-43778

Path traversal in GLPI barcode plugin

HIGH
7.5
CVSS Score
Published: November 24, 2021 at 06:50 PM UTC
Updated: June 17, 2026 at 04:11 AM UTC
2 products affected across 2 vendorsBarcodeProject Barcode

Using barcode by pluginsGLPI?

Get instant alerts when new vulnerabilities affect barcode - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
HIGH7.5
Exploit prediction
EPSS 53%

Description

Barcode is a GLPI plugin for printing barcodes and QR codes. GLPI instances version 2.x prior to version 2.6.1 with the barcode plugin installed are vulnerable to a path traversal vulnerability. This issue was patched in version 2.6.1. As a workaround, delete the `front/send.php` file.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

2.0 ≤ v < 2.6.1
Affected range stops below 2.6.1, so it looks safe — our inference, not a vendor statement
v < 2.6.1
Affected range stops below 2.6.1, so it looks safe — our inference, not a vendor statement

Remediation

No guide yet

No remediation guidance has been written for this CVE yet. What the record does show:

CVSS

Attack Vector
NETWORK
Complexity
LOW
Privileges
NONE
User Interaction
NONE
Scope
UNCHANGED
Confidentiality
HIGH
Integrity
NONE
Availability
NONE
Vector?

Quick Info

StatusMODIFIED
CWE
CWE-22

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card