CVE-2021-43776

XSS vulnerability in @backstage/plugin-auth-backend

MEDIUM
6.1
CVSS Score
Published: November 26, 2021 at 06:15 PM UTC
Updated: June 17, 2026 at 04:11 AM UTC
2 products affected across 2 vendorsAuth BackendBackstage

Using backstage by backstage?

Get instant alerts when new vulnerabilities affect backstage - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
MEDIUM6.1
Exploit prediction
EPSS 0.7%

Description

Backstage is an open platform for building developer portals. In affected versions the auth-backend plugin allows a malicious actor to trick another user into visiting a vulnerable URL that executes an XSS attack. This attack can potentially allow the attacker to exfiltrate access tokens or other secrets from the user's browser. The default CSP does prevent this attack, but it is expected that some deployments have these policies disabled due to incompatibilities. This is vulnerability is patched in version `0.4.9` of `@backstage/plugin-auth-backend`.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

v < 0.4.9
Affected range stops below 0.4.9, so it looks safe — our inference, not a vendor statement
v < 0.4.9
Affected range stops below 0.4.9, so it looks safe — our inference, not a vendor statement

Remediation

No guide yet

No remediation guidance has been written for this CVE yet, and no fixed version or vendor advisory is recorded against it.

CVSS

Attack Vector
NETWORK
Complexity
LOW
Privileges
NONE
User Interaction
REQUIRED
Scope
CHANGED
Confidentiality
LOW
Integrity
LOW
Availability
NONE
Vector?

Quick Info

StatusMODIFIED
CWE
CWE-79

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card