CVE-2021-43083

Apache PLC4X 0.9.0 Buffer overflow in PLC4C via crafted server response

HIGH
8.8
CVSS Score
Published: December 19, 2021 at 08:25 AM UTC
Updated: June 17, 2026 at 04:10 AM UTC
1 product affected across 1 vendorPLC4X

Using Apache PLC4X by Apache Software Foundation?

Get instant alerts when new vulnerabilities affect Apache PLC4X - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
HIGH8.8
Exploit prediction
EPSS 2%

Description

Apache PLC4X - PLC4C (Only the C language implementation was effected) was vulnerable to an unsigned integer underflow flaw inside the tcp transport. Users should update to 0.9.1, which addresses this issue. However, in order to exploit this vulnerability, a user would have to actively connect to a mallicious device which could send a response with invalid content. Currently we consider the probability of this being exploited as quite minimal, however this could change in the future, especially with the industrial networks growing more and more together.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

v < 0.9.1PLC4C ≤ v ≤ 0.9.0PLC4C
Affected range stops below 0.9.1, so it looks safe — our inference, not a vendor statement

Remediation

No guide yet

No remediation guidance has been written for this CVE yet. What the record does show:

References (2)

CVSS

Attack Vector
NETWORK
Complexity
LOW
Privileges
LOW
User Interaction
NONE
Scope
UNCHANGED
Confidentiality
HIGH
Integrity
HIGH
Availability
HIGH
Vector?

Quick Info

StatusMODIFIED
CWE
CWE-119CWE-191

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card