CVE-2021-41598

UI misrepresentation of granted permissions in GitHub Enterprise Server leading to unauthorized access to user

HIGH
8.8
CVSS Score
Published: January 25, 2022 at 07:45 PM UTC
Updated: June 17, 2026 at 04:08 AM UTC
1 product affected across 1 vendorGitHub Enterprise Server

Using GitHub Enterprise Server by GitHub?

Get instant alerts when new vulnerabilities affect GitHub Enterprise Server - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
HIGH8.8
Exploit prediction
EPSS 1%

Description

A UI misrepresentation vulnerability was identified in GitHub Enterprise Server that allowed more permissions to be granted during a GitHub App's user-authorization web flow than was displayed to the user during approval. To exploit this vulnerability, an attacker would need to create a GitHub App on the instance and have a user authorize the application through the web authentication flow. All permissions being granted would properly be shown during the first authorization, but if the user later updated the set of repositories the app was installed on after the GitHub App had configured additional user-level permissions, those additional permissions would not be displayed, leading to more permissions being granted than the user potentially intended. This vulnerability affected all versions of GitHub Enterprise Server prior to 3.3 and was fixed in versions 3.2.5, 3.1.13, 3.0.21. This vulnerability was reported via the GitHub Bug Bounty program.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

v < 3.0.213.0 ≤ v < 3.0.213.1 ≤ v < 3.1.133.1.0 ≤ v < 3.1.133.2 ≤ v < 3.2.53.2.0 ≤ v < 3.2.53.03.13.2
Affected range stops below 3.0.21, so it looks safe — our inference, not a vendor statement
Affected range stops below 3.1.13, so it looks safe — our inference, not a vendor statement
Affected range stops below 3.2.5, so it looks safe — our inference, not a vendor statement

Remediation

No guide yet

No remediation guidance has been written for this CVE yet, and no fixed version or vendor advisory is recorded against it.

CVSS

Attack Vector
NETWORK
Complexity
LOW
Privileges
NONE
User Interaction
REQUIRED
Scope
UNCHANGED
Confidentiality
HIGH
Integrity
HIGH
Availability
HIGH
Vector?

Quick Info

StatusMODIFIED
CWE
CWE-451NVD-CWE-Other

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card