CVE-2021-41177

Rate-limits not working on instances without configured memory cache backend

HIGH
8.1
CVSS Score
Published: October 25, 2021 at 09:50 PM UTC
Updated: June 17, 2026 at 04:08 AM UTC
1 product affected across 1 vendorNextcloud/server

Using security-advisories by nextcloud?

Get instant alerts when new vulnerabilities affect security-advisories - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
HIGH8.1
Exploit prediction
EPSS 2%

Description

Nextcloud is an open-source, self-hosted productivity platform. Prior to versions 20.0.13, 21.0.5, and 22.2.0, Nextcloud Server did not implement a database backend for rate-limiting purposes. Any component of Nextcloud using rate-limits (as as `AnonRateThrottle` or `UserRateThrottle`) was thus not rate limited on instances not having a memory cache backend configured. In the case of a default installation, this would notably include the rate-limits on the two factor codes. It is recommended that the Nextcloud Server be upgraded to 20.0.13, 21.0.5, or 22.2.0. As a workaround, enable a memory cache backend in `config.php`.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

v < 20.0.1321.0.0 ≤ v < 21.0.522.0.0 ≤ v < 22.2.0
Affected range stops below 20.0.13, so it looks safe — our inference, not a vendor statement
Affected range stops below 21.0.5, so it looks safe — our inference, not a vendor statement
Affected range stops below 22.2.0, so it looks safe — our inference, not a vendor statement

Remediation

No guide yet

No remediation guidance has been written for this CVE yet. What the record does show:

References (4)

x_refsource_MISCPatchThird Party Advisory
https://github.com/nextcloud/server/pull/28728
x_refsource_MISCPermissions RequiredThird Party Advisory
https://hackerone.com/reports/1265709
Vendor Advisoryx_refsource_GENTOOThird Party Advisory
https://security.gentoo.org/glsa/202208-17

CVSS

8.1HIGHGitHub_M
Attack Vector
NETWORK
Complexity
LOW
Privileges
LOW
User Interaction
NONE
Scope
UNCHANGED
Confidentiality
HIGH
Integrity
NONE
Availability
HIGH
Vector?

Quick Info

StatusMODIFIED
CWE
CWE-799

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card