CVE-2021-41165

HTML comments vulnerability allowing to execute JavaScript code

MEDIUM
5.4
CVSS Score
Published: November 17, 2021 at 07:15 PM UTC
Updated: June 17, 2026 at 04:08 AM UTC
10 products affected across 3 vendorsDrupalPeopleSoft Enterprise PeopleToolsAgile Product Lifecycle Management

Using ckeditor4 by ckeditor?

Get instant alerts when new vulnerabilities affect ckeditor4 - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
MEDIUM5.4
Exploit prediction
EPSS 2%

Description

CKEditor4 is an open source WYSIWYG HTML editor. In affected version a vulnerability has been discovered in the core HTML processing module and may affect all plugins used by CKEditor 4. The vulnerability allowed to inject malformed comments HTML bypassing content sanitization, which could result in executing JavaScript code. It affects all users using the CKEditor 4 at version < 4.17.0. The problem has been recognized and patched. The fix will be available in version 4.17.0.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

v < 4.17.0
Affected range stops below 4.17.0, so it looks safe — our inference, not a vendor statement
8.9.0 ≤ v < 8.9.209.1.0 ≤ v < 9.1.149.2.0 ≤ v < 9.2.9
Affected range stops below 8.9.20, so it looks safe — our inference, not a vendor statement
Affected range stops below 9.1.14, so it looks safe — our inference, not a vendor statement
Affected range stops below 9.2.9, so it looks safe — our inference, not a vendor statement
v < 22.1
Affected range stops below 22.1, so it looks safe — our inference, not a vendor statement
18.1 ≤ v ≤ 18.319.119.220.121.1
v < 4.17.0
Affected range stops below 4.17.0, so it looks safe — our inference, not a vendor statement

Remediation

No guide yet

No remediation guidance has been written for this CVE yet. What the record does show:

CVSS

Attack Vector
NETWORK
Complexity
LOW
Privileges
LOW
User Interaction
REQUIRED
Scope
CHANGED
Confidentiality
LOW
Integrity
LOW
Availability
NONE
Vector?

Quick Info

StatusMODIFIED
CWE
CWE-79

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card