CVE-2021-41136

Inconsistent Interpretation of HTTP Requests ('HTTP Request Smuggling') in puma

LOW
3.7
CVSS Score
Published: October 12, 2021 at 03:30 PM UTC
Updated: June 17, 2026 at 04:07 AM UTC
2 products affected across 2 vendorsDebian LinuxPuma

Using puma by puma?

Get instant alerts when new vulnerabilities affect puma - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
LOW3.7
Exploit prediction
EPSS 1%

Description

Puma is a HTTP 1.1 server for Ruby/Rack applications. Prior to versions 5.5.1 and 4.3.9, using `puma` with a proxy which forwards HTTP header values which contain the LF character could allow HTTP request smugggling. A client could smuggle a request through a proxy, causing the proxy to send a response back to another unknown client. The only proxy which has this behavior, as far as the Puma team is aware of, is Apache Traffic Server. If the proxy uses persistent connections and the client adds another request in via HTTP pipelining, the proxy may mistake it as the first request's body. Puma, however, would see it as two requests, and when processing the second request, send back a response that the proxy does not expect. If the proxy has reused the persistent connection to Puma to send another request for a different client, the second response from the first client will be sent to the second client. This vulnerability was patched in Puma 5.5.1 and 4.3.9. As a workaround, do not use Apache Traffic Server with `puma`.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

Puma· Pumarubygems
95%
v ≤ 4.3.8v < 4.3.9v < 5.5.15.0.0 ≤ v ≤ 5.5.0
Affected range stops below 4.3.9, so it looks safe — our inference, not a vendor statement
Affected range stops below 5.5.1, so it looks safe — our inference, not a vendor statement

Remediation

No guide yet

No remediation guidance has been written for this CVE yet. What the record does show:

References (7)

Mailing ListThird Party Advisory
Source: af854a3a-2127-422b-91ae-364da2661108
https://lists.debian.org/debian-lts-announce/2022/08/msg00015.html
Third Party Advisory
Source: af854a3a-2127-422b-91ae-364da2661108
https://security.gentoo.org/glsa/202208-28
Third Party Advisory
Source: af854a3a-2127-422b-91ae-364da2661108
https://www.debian.org/security/2022/dsa-5146

CVSS

3.7LOWGitHub_M
Attack Vector
NETWORK
Complexity
HIGH
Privileges
LOW
User Interaction
REQUIRED
Scope
UNCHANGED
Confidentiality
LOW
Integrity
LOW
Availability
NONE
Vector?

Quick Info

StatusMODIFIED
CWE
CWE-444

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card