CVE-2021-41116

Command injection in composer on Windows

CRITICAL
9.8
CVSS Score
Published: October 5, 2021 at 05:40 PM UTC
Updated: June 17, 2026 at 04:07 AM UTC
3 products affected across 3 vendorsTenable.ScComposerComposer

Using composer by composer?

Get instant alerts when new vulnerabilities affect composer - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
CRITICAL9.8
Exploit prediction
EPSS 3%

Description

Composer is an open source dependency manager for the PHP language. In affected versions windows users running Composer to install untrusted dependencies are subject to command injection and should upgrade their composer version. Other OSs and WSL are not affected. The issue has been resolved in composer versions 1.10.23 and 2.1.9. There are no workarounds for this issue.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

v < 1.10.232.0.0 ≤ v < 2.1.9
Affected range stops below 1.10.23, so it looks safe — our inference, not a vendor statement
Affected range stops below 2.1.9, so it looks safe — our inference, not a vendor statement
v < 5.21.0
Affected range stops below 5.21.0, so it looks safe — our inference, not a vendor statement
v < 1.10.23v < 2.1.9
Affected range stops below 1.10.23, so it looks safe — our inference, not a vendor statement
Affected range stops below 2.1.9, so it looks safe — our inference, not a vendor statement

Remediation

No guide yet

No remediation guidance has been written for this CVE yet. What the record does show:

CVSS

Attack Vector
NETWORK
Complexity
LOW
Privileges
NONE
User Interaction
NONE
Scope
UNCHANGED
Confidentiality
HIGH
Integrity
HIGH
Availability
HIGH
Vector?

Quick Info

StatusMODIFIED
CWE
CWE-77

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card