CVE-2021-41103

Insufficiently restricted permissions on plugin directories

HIGH
7.8
CVSS Score
Published: October 4, 2021 at 12:00 AM UTC
Updated: June 17, 2026 at 04:07 AM UTC
4 products affected across 4 vendorsDebian LinuxFedoraContainerd

Using containerd by containerd?

Get instant alerts when new vulnerabilities affect containerd - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
HIGH7.8
Exploit prediction
EPSS 0.5%

Description

containerd is an open source container runtime with an emphasis on simplicity, robustness and portability. A bug was found in containerd where container root directories and some plugins had insufficiently restricted permissions, allowing otherwise unprivileged Linux users to traverse directory contents and execute programs. When containers included executable programs with extended permission bits (such as setuid), unprivileged Linux users could discover and execute those programs. When the UID of an unprivileged Linux user on the host collided with the file owner or group inside a container, the unprivileged Linux user on the host could discover, read, and modify those files. This vulnerability has been fixed in containerd 1.4.11 and containerd 1.5.7. Users should update to these version when they are released and may restart containers or update directory permissions to mitigate the vulnerability. Users unable to update should limit access to the host to trusted users. Update directory permission on container bundles directories.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

v < 1.4.111.5.0 ≤ v < 1.5.7
Affected range stops below 1.4.11, so it looks safe — our inference, not a vendor statement
Affected range stops below 1.5.7, so it looks safe — our inference, not a vendor statement
v < 1.4.11v < 1.5.7
Affected range stops below 1.4.11, so it looks safe — our inference, not a vendor statement
Affected range stops below 1.5.7, so it looks safe — our inference, not a vendor statement

CVSS

Attack Vector
LOCAL
Complexity
LOW
Privileges
LOW
User Interaction
NONE
Scope
UNCHANGED
Confidentiality
HIGH
Integrity
HIGH
Availability
HIGH
Vector?

Quick Info

StatusMODIFIED
CWE
CWE-22

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card