CVE-2021-40111

Apache James IMAP parsing Denial Of Service

MEDIUM
6.5
CVSS Score
Published: January 4, 2022 at 08:55 AM UTC
Updated: June 17, 2026 at 04:06 AM UTC
1 product affected across 1 vendorJames

Using Apache James by Apache Software Foundation?

Get instant alerts when new vulnerabilities affect Apache James - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
MEDIUM6.5
Exploit prediction
EPSS 2%

Description

In Apache James, while fuzzing with Jazzer the IMAP parsing stack, we discover that crafted APPEND and STATUS IMAP command could be used to trigger infinite loops resulting in expensive CPU computations and OutOfMemory exceptions. This can be used for a Denial Of Service attack. The IMAP user needs to be authenticated to exploit this vulnerability. This affected Apache James prior to version 3.6.1. This vulnerability had been patched in Apache James 3.6.1 and higher. We recommend the upgrade.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

v < 3.6.1Apache James ≤ v ≤ 3.6.0
Affected range stops below 3.6.1, so it looks safe — our inference, not a vendor statement

Remediation

No guide yet

No remediation guidance has been written for this CVE yet, and no fixed version or vendor advisory is recorded against it.

References (2)

Mailing Listx_refsource_MLISTThird Party Advisory
http://www.openwall.com/lists/oss-security/2022/01/04/3
x_refsource_MISCMailing ListThird Party Advisory
https://www.openwall.com/lists/oss-security/2022/01/04/3

CVSS

Attack Vector
NETWORK
Complexity
LOW
Privileges
LOW
User Interaction
NONE
Scope
UNCHANGED
Confidentiality
NONE
Integrity
NONE
Availability
HIGH
Vector?

Quick Info

StatusMODIFIED
CWE
CWE-835

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card