CVE-2021-40110

Apache James IMAP vulnerable to a ReDoS

HIGH
7.5
CVSS Score
Published: January 4, 2022 at 08:55 AM UTC
Updated: June 17, 2026 at 04:06 AM UTC
1 product affected across 1 vendorJames

Using Apache James by Apache Software Foundation?

Get instant alerts when new vulnerabilities affect Apache James - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
HIGH7.5
Exploit prediction
EPSS 3%

Description

In Apache James, using Jazzer fuzzer, we identified that an IMAP user can craft IMAP LIST commands to orchestrate a Denial Of Service using a vulnerable Regular expression. This affected Apache James prior to 3.6.1 We recommend upgrading to Apache James 3.6.1 or higher , which enforce the use of RE2J regular expression engine to execute regex in linear time without back-tracking.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

v < 3.6.1Apache James ≤ v ≤ 3.6.0
Affected range stops below 3.6.1, so it looks safe — our inference, not a vendor statement

Remediation

No guide yet

No remediation guidance has been written for this CVE yet, and no fixed version or vendor advisory is recorded against it.

References (2)

Mailing Listx_refsource_MLISTThird Party Advisory
http://www.openwall.com/lists/oss-security/2022/01/04/2
x_refsource_MISCMailing ListThird Party Advisory
https://www.openwall.com/lists/oss-security/2022/01/04/2

CVSS

Attack Vector
NETWORK
Complexity
LOW
Privileges
NONE
User Interaction
NONE
Scope
UNCHANGED
Confidentiality
NONE
Integrity
NONE
Availability
HIGH
Vector?

Quick Info

StatusMODIFIED
CWE
NVD-CWE-Other

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card