CVE-2021-3939

Free of static data in accountsservice

HIGH
7.8
CVSS Score
Published: November 17, 2021 at 03:15 AM UTC
Updated: June 17, 2026 at 04:06 AM UTC
3 products affected across 2 vendorsUbuntu LinuxAccountsserviceAccountsservice

Using accountsservice by Ubuntu?

Get instant alerts when new vulnerabilities affect accountsservice - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
HIGH7.8
Exploit prediction
EPSS 0.4%

Description

Ubuntu-specific modifications to accountsservice (in patch file debian/patches/0010-set-language.patch) caused the fallback_locale variable, pointing to static storage, to be freed, in the user_change_language_authorized_cb function. This is reachable via the SetLanguage dbus function. This is fixed in versions 0.6.55-0ubuntu12~20.04.5, 0.6.55-0ubuntu13.3, 0.6.55-0ubuntu14.1.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

0.6.55-0ubuntu12\~20.04 ≤ v < 0.6.55-0ubuntu12\~20.050.6.55-0ubuntu13 ≤ v < 0.6.55-0ubuntu13.30.6.55-0ubuntu14 ≤ v < 0.6.55-0ubuntu14.1
Affected range stops below 0.6.55-0ubuntu12~20.05, so it looks safe — our inference, not a vendor statement
Affected range stops below 0.6.55-0ubuntu13.3, so it looks safe — our inference, not a vendor statement
Affected range stops below 0.6.55-0ubuntu14.1, so it looks safe — our inference, not a vendor statement
0.6.55-0ubuntu12~20.04 ≤ v < 0.6.55-0ubuntu12~20.04.50.6.55-0ubuntu13 ≤ v < 0.6.55-0ubuntu13.30.6.55-0ubuntu14 ≤ v < 0.6.55-0ubuntu14.10.6.55-0ubuntu12~20.040.6.55-0ubuntu130.6.55-0ubuntu14
Affected range stops below 0.6.55-0ubuntu12~20.04.5, so it looks safe — our inference, not a vendor statement
Affected range stops below 0.6.55-0ubuntu13.3, so it looks safe — our inference, not a vendor statement
Affected range stops below 0.6.55-0ubuntu14.1, so it looks safe — our inference, not a vendor statement

Remediation

No guide yet

No remediation guidance has been written for this CVE yet. What the record does show:

CVSS

7.8HIGHcanonical
Attack Vector
LOCAL
Complexity
HIGH
Privileges
LOW
User Interaction
NONE
Scope
CHANGED
Confidentiality
HIGH
Integrity
HIGH
Availability
HIGH
Vector?

Quick Info

StatusMODIFIED
CWE
CWE-590CWE-763

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card