CVE-2021-39201

Authenticated cross-site scripting (XSS) in WordPress editor

MEDIUM
5.4
CVSS Score
Published: September 9, 2021 at 09:35 PM UTC
Updated: June 17, 2026 at 04:03 AM UTC
2 products affected across 2 vendorsDebian LinuxWordPress

Using wordpress-develop by WordPress?

Get instant alerts when new vulnerabilities affect wordpress-develop - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
MEDIUM5.4
Exploit prediction
EPSS 1%

Description

WordPress is a free and open-source content management system written in PHP and paired with a MySQL or MariaDB database. ### Impact The issue allows an authenticated but low-privileged user (like contributor/author) to execute XSS in the editor. This bypasses the restrictions imposed on users who do not have the permission to post `unfiltered_html`. ### Patches This has been patched in WordPress 5.8, and will be pushed to older versions via minor releases (automatic updates). It's strongly recommended that you keep auto-updates enabled to receive the fix. ### References https://wordpress.org/news/category/releases/ https://hackerone.com/reports/1142140 ### For more information If you have any questions or comments about this advisory: * Open an issue in [HackerOne](https://hackerone.com/wordpress)

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

v < 5.8.05.0 ≤ v < 5.8
Affected range stops below 5.8, so it looks safe — our inference, not a vendor statement
Affected range stops below 5.8.0, so it looks safe — our inference, not a vendor statement

Remediation

No guide yet

No remediation guidance has been written for this CVE yet. What the record does show:

References (3)

x_refsource_MISCPermissions Required
https://hackerone.com/reports/1142140
Vendor Advisoryx_refsource_DEBIANThird Party Advisory
https://www.debian.org/security/2021/dsa-4985

CVSS

Attack Vector
NETWORK
Complexity
LOW
Privileges
LOW
User Interaction
REQUIRED
Scope
CHANGED
Confidentiality
LOW
Integrity
LOW
Availability
NONE
Vector?

Quick Info

StatusMODIFIED
CWE
CWE-79

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card