CVE-2021-39200

Information Disclosure in wp_die() via JSONP in wordpress

MEDIUM
5.3
CVSS Score
Published: September 9, 2021 at 09:25 PM UTC
Updated: June 17, 2026 at 04:03 AM UTC
2 products affected across 2 vendorsDebian LinuxWordPress

Using wordpress-develop by WordPress?

Get instant alerts when new vulnerabilities affect wordpress-develop - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
MEDIUM5.3
Exploit prediction
EPSS 2%

Description

WordPress is a free and open-source content management system written in PHP and paired with a MySQL or MariaDB database. In affected versions output data of the function wp_die() can be leaked under certain conditions, which can include data like nonces. It can then be used to perform actions on your behalf. This has been patched in WordPress 5.8.1, along with any older affected versions via minor releases. It's strongly recommended that you keep auto-updates enabled to receive the fix.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

v < 5.8.15.2 ≤ v < 5.8.1
Affected range stops below 5.8.1, so it looks safe — our inference, not a vendor statement

Remediation

No guide yet

No remediation guidance has been written for this CVE yet. What the record does show:

References (3)

x_refsource_MISCPermissions Required
https://hackerone.com/reports/1142140
Vendor Advisoryx_refsource_DEBIANThird Party Advisory
https://www.debian.org/security/2021/dsa-4985

CVSS

5.3MEDIUMGitHub_M
Attack Vector
NETWORK
Complexity
HIGH
Privileges
LOW
User Interaction
NONE
Scope
UNCHANGED
Confidentiality
HIGH
Integrity
NONE
Availability
NONE
Vector?

Quick Info

StatusMODIFIED
CWE
CWE-200

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card