CVE-2021-39180

Path Traversal in Archive Handling Leading to Code Execution

HIGH
8.8
CVSS Score
Published: August 31, 2021 at 05:55 PM UTC
Updated: June 17, 2026 at 04:03 AM UTC
2 products affected across 2 vendorsOpenolatOpenOLAT

Using OpenOLAT by OpenOLAT?

Get instant alerts when new vulnerabilities affect OpenOLAT - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
HIGH8.8
Exploit prediction
EPSS 2%

Description

OpenOLAT is a web-based learning management system (LMS). A path traversal vulnerability exists in versions prior to 15.3.18, 15.5.3, and 16.0.0. Using a specially prepared ZIP file, it is possible to overwrite any file that is writable by the application server user (e.g. the tomcat user). Depending on the configuration this can be limited to files of the OpenOlat user data directory, however, if not properly set up, the attack could also be used to overwrite application server config files, java code or even operating system files. The attack could be used to corrupt or modify any OpenOlat file such as course structures, config files or temporary test data. Those attack would require in-depth knowledge of the installation and thus more theoretical. If the app server configuration allows the execution of jsp files and the path to the context is known, it is also possible to execute java code. If the app server runs with the same user that is used to deploy the OpenOlat code or has write permissions on the OpenOlat code files and the path to the context is know, code injection is possible. The attack requires an OpenOlat user account to upload a ZIP file and trigger the unzip method. It can not be exploited by unregistered users. The problem is fixed in versions 15.3.18, 15.5.3 and 16.0.0. There are no known workarounds aside from upgrading.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

v < 15.3.1815.4.0 ≤ v < 15.5.3
Affected range stops below 15.3.18, so it looks safe — our inference, not a vendor statement
Affected range stops below 15.5.3, so it looks safe — our inference, not a vendor statement
v < 15.3.18v < 15.5.3
Affected range stops below 15.3.18, so it looks safe — our inference, not a vendor statement
Affected range stops below 15.5.3, so it looks safe — our inference, not a vendor statement

CVSS

Attack Vector
NETWORK
Complexity
LOW
Privileges
LOW
User Interaction
NONE
Scope
UNCHANGED
Confidentiality
HIGH
Integrity
HIGH
Availability
HIGH
Vector?

Quick Info

StatusMODIFIED
CWE
CWE-22

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card