CVE-2021-39135

UNIX Symbolic Link (Symlink) Following in @npmcli/arborist

HIGH
7.8
CVSS Score
Published: August 31, 2021 at 05:10 PM UTC
Updated: June 17, 2026 at 04:03 AM UTC
5 products affected across 4 vendorsGraalVMSinec Infrastructure Network ServicesArborist

Using arborist by npm?

Get instant alerts when new vulnerabilities affect arborist - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
HIGH7.8
Exploit prediction
EPSS 0.6%

Description

`@npmcli/arborist`, the library that calculates dependency trees and manages the node_modules folder hierarchy for the npm command line interface, aims to guarantee that package dependency contracts will be met, and the extraction of package contents will always be performed into the expected folder. This is accomplished by extracting package contents into a project's `node_modules` folder. If the `node_modules` folder of the root project or any of its dependencies is somehow replaced with a symbolic link, it could allow Arborist to write package dependencies to any arbitrary location on the file system. Note that symbolic links contained within package artifact contents are filtered out, so another means of creating a `node_modules` symbolic link would have to be employed. 1. A `preinstall` script could replace `node_modules` with a symlink. (This is prevented by using `--ignore-scripts`.) 2. An attacker could supply the target with a git repository, instructing them to run `npm install --ignore-scripts` in the root. This may be successful, because `npm install --ignore-scripts` is typically not capable of making changes outside of the project directory, so it may be deemed safe. This is patched in @npmcli/arborist 2.8.2 which is included in npm v7.20.7 and above. For more information including workarounds please see the referenced GHSA-gmw6-94gg-2rc2.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

v < 2.8.2
Affected range stops below 2.8.2, so it looks safe — our inference, not a vendor statement
npmjs-npm (environment)
v < 1.0.1.1
Affected range stops below 1.0.1.1, so it looks safe — our inference, not a vendor statement
v < 2.8.2
Affected range stops below 2.8.2, so it looks safe — our inference, not a vendor statement
80%
All versions

Remediation

No guide yet

No remediation guidance has been written for this CVE yet. What the record does show:

CVSS

Attack Vector
LOCAL
Complexity
LOW
Privileges
NONE
User Interaction
REQUIRED
Scope
UNCHANGED
Confidentiality
HIGH
Integrity
HIGH
Availability
HIGH
Vector?

Quick Info

StatusMODIFIED
CWE
CWE-61CWE-59

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card