CVE-2021-39134

UNIX Symbolic Link (Symlink) Following in @npmcli/arborist

HIGH
7.8
CVSS Score
Published: August 31, 2021 at 04:55 PM UTC
Updated: June 17, 2026 at 04:03 AM UTC
5 products affected across 4 vendorsGraalVMSinec Infrastructure Network ServicesArborist

Using arborist by npm?

Get instant alerts when new vulnerabilities affect arborist - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
HIGH7.8
Exploit prediction
EPSS 0.6%

Description

`@npmcli/arborist`, the library that calculates dependency trees and manages the `node_modules` folder hierarchy for the npm command line interface, aims to guarantee that package dependency contracts will be met, and the extraction of package contents will always be performed into the expected folder. This is, in part, accomplished by resolving dependency specifiers defined in `package.json` manifests for dependencies with a specific name, and nesting folders to resolve conflicting dependencies. When multiple dependencies differ only in the case of their name, Arborist's internal data structure saw them as separate items that could coexist within the same level in the `node_modules` hierarchy. However, on case-insensitive file systems (such as macOS and Windows), this is not the case. Combined with a symlink dependency such as `file:/some/path`, this allowed an attacker to create a situation in which arbitrary contents could be written to any location on the filesystem. For example, a package `pwn-a` could define a dependency in their `package.json` file such as `"foo": "file:/some/path"`. Another package, `pwn-b` could define a dependency such as `FOO: "file:foo.tgz"`. On case-insensitive file systems, if `pwn-a` was installed, and then `pwn-b` was installed afterwards, the contents of `foo.tgz` would be written to `/some/path`, and any existing contents of `/some/path` would be removed. Anyone using npm v7.20.6 or earlier on a case-insensitive filesystem is potentially affected. This is patched in @npmcli/arborist 2.8.2 which is included in npm v7.20.7 and above.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

v < 2.8.2
Affected range stops below 2.8.2, so it looks safe — our inference, not a vendor statement
npmjs-npm (environment)
v < 1.0.1.1
Affected range stops below 1.0.1.1, so it looks safe — our inference, not a vendor statement
v < 2.8.2
Affected range stops below 2.8.2, so it looks safe — our inference, not a vendor statement
80%
All versions

Remediation

No guide yet

No remediation guidance has been written for this CVE yet. What the record does show:

CVSS

Attack Vector
LOCAL
Complexity
LOW
Privileges
NONE
User Interaction
REQUIRED
Scope
UNCHANGED
Confidentiality
HIGH
Integrity
HIGH
Availability
HIGH
Vector?

Quick Info

StatusMODIFIED
CWE
CWE-61CWE-178

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card