CVE-2021-37705

Improper Authorization and Origin Validation Error in OneFuzz

CRITICAL
10
CVSS Score
Published: August 13, 2021 at 08:15 PM UTC
Updated: June 17, 2026 at 04:01 AM UTC
1 product affected across 1 vendorOnefuzz

Using onefuzz by microsoft?

Get instant alerts when new vulnerabilities affect onefuzz - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
CRITICAL10
Exploit prediction
EPSS 2%

Description

OneFuzz is an open source self-hosted Fuzzing-As-A-Service platform. Starting with OneFuzz 2.12.0 or greater, an incomplete authorization check allows an authenticated user from any Azure Active Directory tenant to make authorized API calls to a vulnerable OneFuzz instance. To be vulnerable, a OneFuzz deployment must be both version 2.12.0 or greater and deployed with the non-default --multi_tenant_domain option. This can result in read/write access to private data such as software vulnerability and crash information, security testing tools and proprietary code and symbols. Via authorized API calls, this also enables tampering with existing data and unauthorized code execution on Azure compute resources. This issue is resolved starting in release 2.31.0, via the addition of application-level check of the bearer token's `issuer` against an administrator-configured allowlist. As a workaround users can restrict access to the tenant of a deployed OneFuzz instance < 2.31.0 by redeploying in the default configuration, which omits the `--multi_tenant_domain` option.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

v < 2.31.02.12.0 ≤ v < 2.31.0
Affected range stops below 2.31.0, so it looks safe — our inference, not a vendor statement

Remediation

No guide yet

No remediation guidance has been written for this CVE yet. What the record does show:

CVSS

10CRITICALGitHub_M
Attack Vector
NETWORK
Complexity
LOW
Privileges
NONE
User Interaction
NONE
Scope
CHANGED
Confidentiality
HIGH
Integrity
HIGH
Availability
LOW
Vector?

Quick Info

StatusMODIFIED
CWE
CWE-285CWE-346CWE-863

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card