CVE-2021-3731

Improper Restriction of Rendered UI Layers or Frames in ledgersmb/ledgersmb

MEDIUM
4.7
CVSS Score
Published: August 23, 2021 at 12:42 PM UTC
Updated: June 17, 2026 at 04:05 AM UTC
2 products affected across 2 vendorsDebian LinuxLedgersmb

Using ledgersmb/ledgersmb by ledgersmb?

Get instant alerts when new vulnerabilities affect ledgersmb/ledgersmb - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
MEDIUM4.7
Exploit prediction
EPSS 1%

Description

LedgerSMB does not sufficiently guard against being wrapped by other sites, making it vulnerable to 'clickjacking'. This allows an attacker to trick a targetted user to execute unintended actions.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

v < 1.8.181.1.0 ≤ v ≤ 1.1.121.2.0 ≤ v ≤ 1.2.261.3.0 ≤ v ≤ 1.3.471.4.0 ≤ v ≤ 1.4.421.5.0 ≤ v ≤ 1.5.301.6.0 ≤ v ≤ 1.6.331.7.0 ≤ v ≤ 1.7.321.8.0 ≤ v ≤ 1.8.17
Vendor states this is fixed in 1.7.33 (unaffected)
Affected range stops below 1.8.18, so it looks safe — our inference, not a vendor statement

Remediation

No guide yet

No remediation guidance has been written for this CVE yet. What the record does show:

References (3)

Vendor Advisoryx_refsource_DEBIANThird Party Advisory
https://www.debian.org/security/2021/dsa-4962

CVSS

Attack Vector
NETWORK
Complexity
LOW
Privileges
NONE
User Interaction
REQUIRED
Scope
CHANGED
Confidentiality
NONE
Integrity
LOW
Availability
NONE
Vector?

Quick Info

StatusMODIFIED
CWE
CWE-1021

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card