CVE-2021-3677

MEDIUM
6.5
CVSS Score
Published: March 2, 2022 at 12:00 AM UTC
Updated: June 17, 2026 at 04:05 AM UTC
7 products affected across 3 vendorsFedoraEnterprise LinuxPostgreSQL

Using postgresql by N/A?

Get instant alerts when new vulnerabilities affect postgresql - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
MEDIUM6.5
Exploit prediction
EPSS 1%

Description

A flaw was found in postgresql. A purpose-crafted query can read arbitrary bytes of server memory. In the default configuration, any authenticated database user can complete this attack at will. The attack does not require the ability to create objects. If server settings include max_worker_processes=0, the known versions of this attack are infeasible. However, undiscovered variants of the attack may be independent of that setting.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

11.0 ≤ v < 11.1312.0 ≤ v < 12.813.0 ≤ v < 13.4Fixedin v13.4, v12.8, v11.13
Affected range stops below 11.13, so it looks safe — our inference, not a vendor statement
Affected range stops below 12.8, so it looks safe — our inference, not a vendor statement
Affected range stops below 13.4, so it looks safe — our inference, not a vendor statement
redhat-enterprise-linux (environment)

Remediation

No guide yet

No remediation guidance has been written for this CVE yet. What the record does show:

CVSS

Attack Vector
NETWORK
Complexity
LOW
Privileges
LOW
User Interaction
NONE
Scope
UNCHANGED
Confidentiality
HIGH
Integrity
NONE
Availability
NONE
Vector?

Quick Info

StatusMODIFIED
CWE
CWE-200NVD-CWE-noinfo

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card