CVE-2021-32829

Post-authentication Remote Code Execution (RCE) in ZStack REST API

CRITICAL
9.9
CVSS Score
Published: August 17, 2021 at 04:00 PM UTC
Updated: June 17, 2026 at 03:53 AM UTC
2 products affected across 2 vendorsRest APIZstack

Using zstack by zstackio?

Get instant alerts when new vulnerabilities affect zstack - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
CRITICAL9.9
Exploit prediction
EPSS 3%

Description

ZStack is open source IaaS(infrastructure as a service) software aiming to automate datacenters, managing resources of compute, storage, and networking all by APIs. Affected versions of ZStack REST API are vulnerable to post-authentication Remote Code Execution (RCE) via bypass of the Groovy shell sandbox. The REST API exposes the GET zstack/v1/batch-queries?script endpoint which is backed up by the BatchQueryAction class. Messages are represented by the APIBatchQueryMsg, dispatched to the QueryFacadeImpl facade and handled by the BatchQuery class. The HTTP request parameter script is mapped to the APIBatchQueryMsg.script property and evaluated as a Groovy script in BatchQuery.query the evaluation of the user-controlled Groovy script is sandboxed by SandboxTransformer which will apply the restrictions defined in the registered (sandbox.register()) GroovyInterceptor. Even though the sandbox heavily restricts the receiver types to a small set of allowed types, the sandbox is non effective at controlling any code placed in Java annotations and therefore vulnerable to meta-programming escapes. This issue leads to post-authenticated remote code execution. For more details see the referenced GHSL-2021-065. This issue is patched in versions 3.8.21, 3.10.8, and 4.1.0.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

2.2.4 ≤ v < 3.8.213.10.0 ≤ v < 3.10.8
Affected range stops below 3.10.8, so it looks safe — our inference, not a vendor statement
Affected range stops below 3.8.21, so it looks safe — our inference, not a vendor statement
v < 3.10.8v < 3.8.21v < 4.1.0
Affected range stops below 3.10.8, so it looks safe — our inference, not a vendor statement
Affected range stops below 3.8.21, so it looks safe — our inference, not a vendor statement
Affected range stops below 4.1.0, so it looks safe — our inference, not a vendor statement

Remediation

No guide yet

No remediation guidance has been written for this CVE yet, and no fixed version or vendor advisory is recorded against it.

CVSS

Attack Vector
NETWORK
Complexity
LOW
Privileges
LOW
User Interaction
NONE
Scope
CHANGED
Confidentiality
HIGH
Integrity
HIGH
Availability
HIGH
Vector?

Quick Info

StatusMODIFIED
CWE
CWE-94CWE-863

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card