CVE-2021-32809

Arbitrary HTML injection vulnerability in ckeditor

MEDIUM
5.4
CVSS Score
Published: August 12, 2021 at 05:10 PM UTC
Updated: June 17, 2026 at 03:53 AM UTC
11 products affected across 3 vendorsFedoraPeopleSoft Enterprise PeopleToolsJD Edwards EnterpriseOne Tools

Using ckeditor4 by ckeditor?

Get instant alerts when new vulnerabilities affect ckeditor4 - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
MEDIUM5.4
Exploit prediction
EPSS 1%

Description

ckeditor is an open source WYSIWYG HTML editor with rich content support. A potential vulnerability has been discovered in CKEditor 4 [Clipboard](https://ckeditor.com/cke4/addon/clipboard) package. The vulnerability allowed to abuse paste functionality using malformed HTML, which could result in injecting arbitrary HTML into the editor. It affects all users using the CKEditor 4 plugins listed above at version >= 4.5.2. The problem has been recognized and patched. The fix will be available in version 4.16.2.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

4.5.2 ≤ v < 4.16.2
Affected range stops below 4.16.2, so it looks safe — our inference, not a vendor statement
v < 21.1.4
Affected range stops below 21.1.4, so it looks safe — our inference, not a vendor statement
v < 9.2.6.0
Affected range stops below 9.2.6.0, so it looks safe — our inference, not a vendor statement

CVSS

Attack Vector
NETWORK
Complexity
LOW
Privileges
LOW
User Interaction
REQUIRED
Scope
CHANGED
Confidentiality
LOW
Integrity
LOW
Availability
NONE
Vector?

Quick Info

StatusMODIFIED
CWE
CWE-94CWE-79

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card