CVE-2021-32768

Cross-Site Scripting via Rich-Text Content

MEDIUM
6.1
CVSS Score
Published: August 10, 2021 at 04:30 PM UTC
Updated: June 17, 2026 at 03:53 AM UTC
1 product affected across 1 vendorTYPO3

Using TYPO3.CMS by TYPO3?

Get instant alerts when new vulnerabilities affect TYPO3.CMS - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
MEDIUM6.1
Exploit prediction
EPSS 0.7%

Description

TYPO3 is an open source PHP based web content management system released under the GNU GPL. In affected versions failing to properly parse, sanitize and encode malicious rich-text content, the content rendering process in the website frontend is vulnerable to cross-site scripting. Corresponding rendering instructions via TypoScript functionality HTMLparser does not consider all potentially malicious HTML tag & attribute combinations per default. In default scenarios, a valid backend user account is needed to exploit this vulnerability. In case custom plugins used in the website frontend accept and reflect rich-text content submitted by users, no authentication is required. Update to TYPO3 versions 7.6.53 ELTS, 8.7.42 ELTS, 9.5.29, 10.4.19, 11.3.2 that fix the problem described.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

95%
v < 10.4.19v < 11.3.2v < 7.6.53v < 8.7.42v < 9.5.2910.0.0 ≤ v ≤ 10.4.1811.0.0 ≤ v ≤ 11.3.17.0.0 ≤ v ≤ 7.6.528.0.0 ≤ v ≤ 8.7.419.0.0 ≤ v ≤ 9.5.28
Affected range stops below 10.4.19, so it looks safe — our inference, not a vendor statement
Affected range stops below 11.3.2, so it looks safe — our inference, not a vendor statement
Affected range stops below 7.6.53, so it looks safe — our inference, not a vendor statement
Affected range stops below 8.7.42, so it looks safe — our inference, not a vendor statement
Affected range stops below 9.5.29, so it looks safe — our inference, not a vendor statement

Remediation

No guide yet

No remediation guidance has been written for this CVE yet. What the record does show:

CVSS

6.1MEDIUMGitHub_M
Attack Vector
NETWORK
Complexity
LOW
Privileges
NONE
User Interaction
REQUIRED
Scope
CHANGED
Confidentiality
LOW
Integrity
LOW
Availability
NONE
Vector?

Quick Info

StatusMODIFIED
CWE
CWE-79

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card