CVE-2021-32740

Regular Expression Denial of Service in Addressable templates

HIGH
7.5
CVSS Score
Published: July 6, 2021 at 02:15 PM UTC
Updated: June 17, 2026 at 03:53 AM UTC
3 products affected across 3 vendorsFedoraAddressableAddressable

Using addressable by sporkmonger?

Get instant alerts when new vulnerabilities affect addressable - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
HIGH7.5
Exploit prediction
EPSS 2%

Description

Addressable is an alternative implementation to the URI implementation that is part of Ruby's standard library. An uncontrolled resource consumption vulnerability exists after version 2.3.0 through version 2.7.0. Within the URI template implementation in Addressable, a maliciously crafted template may result in uncontrolled resource consumption, leading to denial of service when matched against a URI. In typical usage, templates would not normally be read from untrusted user input, but nonetheless, no previous security advisory for Addressable has cautioned against doing this. Users of the parsing capabilities in Addressable but not the URI template capabilities are unaffected. The vulnerability is patched in version 2.8.0. As a workaround, only create Template objects from trusted sources that have been validated not to produce catastrophic backtracking.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

2.3.0 ≤ v < 2.8.0
Affected range stops below 2.8.0, so it looks safe — our inference, not a vendor statement

CVSS

7.5HIGHGitHub_M
Attack Vector
NETWORK
Complexity
LOW
Privileges
NONE
User Interaction
NONE
Scope
UNCHANGED
Confidentiality
NONE
Integrity
NONE
Availability
HIGH
Vector?

Quick Info

StatusMODIFIED
CWE
CWE-400

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card