CVE-2021-32678

Ratelimit not applied on OCS API responses

MEDIUM
5.3
CVSS Score
Published: July 12, 2021 at 12:25 PM UTC
Updated: June 17, 2026 at 03:53 AM UTC
2 products affected across 2 vendorsFedoraNextcloud/server

Using security-advisories by nextcloud?

Get instant alerts when new vulnerabilities affect security-advisories - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
MEDIUM5.3
Exploit prediction
EPSS 1%

Description

Nextcloud Server is a Nextcloud package that handles data storage. In versions prior to 19.0.13, 20.0.11, and 21.0.3, ratelimits are not applied to OCS API responses. This affects any OCS API controller (`OCSController`) using the `@BruteForceProtection` annotation. Risk depends on the installed applications on the Nextcloud Server, but could range from bypassing authentication ratelimits or spamming other Nextcloud users. The vulnerability is patched in versions 19.0.13, 20.0.11, and 21.0.3. No workarounds aside from upgrading are known to exist.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

v < 19.0.1320.0.0 ≤ v < 20.0.1121.0.0 ≤ v < 21.0.3
Affected range stops below 19.0.13, so it looks safe — our inference, not a vendor statement
Affected range stops below 20.0.11, so it looks safe — our inference, not a vendor statement
Affected range stops below 21.0.3, so it looks safe — our inference, not a vendor statement

CVSS

Attack Vector
NETWORK
Complexity
LOW
Privileges
NONE
User Interaction
NONE
Scope
UNCHANGED
Confidentiality
NONE
Integrity
LOW
Availability
NONE
Vector?

Quick Info

StatusMODIFIED
CWE
CWE-799CWE-307

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card